Apache Airflow vulnerable to Improper Encoding or Escaping of Output
CVE-2024-45498GHSA-c392-whpc-vfpr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 2.10.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow
- Affected
- >= 2.10.0, <= 2.10.0
- Fixed in
- 2.10.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c392-whpc-vfpr lists affected ranges: PyPI apache-airflow >=2.10.0 <2.10.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c392-whpc-vfpr lists affected ranges: PyPI apache-airflow >=2.10.0 <=2.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-45498: 1.24% estimated exploitation activity in the next 30 days; percentile 69.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Example DAG: exampleinleteventextra.py shipped with Apache Airflow version 2.10.0 has a vulnerability that allows an authenticated attacker with only DAG trigger permission to execute arbitrary commands. If you used that example as the base of your DAGs - please review if you have not copied the dangerous example; see https://github.com/apache/airflow/pull/41873 for more information. We recommend against exposing the example DAGs in your deployment. If you must expose the example DAGs, upgrade Airflow to version 2.10.1 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-c392-whpc-vfpr
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-c392-whpc-vfpr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-45498 Advisory: Apache Airflow vulnerable to Improper Encoding or Escaping of Output IDs: CVE-2024-45498, GHSA-c392-whpc-vfpr Record: https://patchnext.com/advisories/cve-2024-45498 (revision 3, source checked 26 Oct 2026, 13:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow 2.10.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow: affected >= 2.10.0, <= 2.10.0; fixed in 2.10.1 ## Suggested inspection (read-only) - `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c392-whpc-vfpr (OSV record GHSA-c392-whpc-vfpr lists affected ranges: PyPI apache-airflow >=2.10.0 <2.10.1 (fixed)) - Verified: https://github.com/advisories/GHSA-c392-whpc-vfpr (GitHub-reviewed advisory GHSA-c392-whpc-vfpr lists affected ranges: PyPI apache-airflow >=2.10.0 <=2.10.0) Commands are suggestions: review each one before running it.
Loading voting…