Skip to content

← Actionable
Medium, CVSS 5.8

Twig has a possible sandbox bypass

CVE-2024-45411GHSA-6j75-5wfj-gh66

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (twig/twig 3.14.0, 3.11.1, 2.16.1, 1.44.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist twig/twig

    Affected
    >= 1.0.0, < 1.44.8>= 2.0.0, < 2.16.1>= 3.12.0, < 3.14.0>= 3.0.0, < 3.11.1
    Fixed in
    1.44.8, 3.14.0, 2.16.1, 3.11.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.8 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2024-45411: 0.85% estimated exploitation activity in the next 30 days; percentile 58.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description Under some circumstances, the sandbox security checks are not run which allows user-contributed templates to bypass the sandbox restrictions. The security issue happens when all these conditions are met: The sandbox is disabled globally; The sandbox is enabled via a sandboxed include() function which references a template name (like included.twig) and not a Template or TemplateWrapper instance; The included template has been loaded before the include() call but in a non-sandbox context (possible as the sandbox has been globally disabled). Resolution The patch ensures that the sandbox security checks are always run at runtime. Credits We would like to thank Fabien Potencier for reporting and fixing the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6j75-5wfj-gh66

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-45411

Advisory: Twig has a possible sandbox bypass
IDs: CVE-2024-45411, GHSA-6j75-5wfj-gh66
Record: https://patchnext.com/advisories/cve-2024-45411 (revision 1, source checked 26 Oct 2026, 14:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: twig/twig 3.14.0, 3.11.1, 2.16.1, 1.44.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist twig/twig: affected >= 1.0.0, < 1.44.8; >= 2.0.0, < 2.16.1; >= 3.12.0, < 3.14.0; >= 3.0.0, < 3.11.1; fixed in 1.44.8, 3.14.0, 2.16.1, 3.11.1

## Suggested inspection (read-only)
- Packagist twig/twig: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on twig/twig.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6j75-5wfj-gh66 (GitHub-reviewed advisory GHSA-6j75-5wfj-gh66 lists affected ranges: Packagist twig/twig >=1.0.0 =2.0.0 =3.12.0 =3.0.0 <3.11.1)

Commands are suggestions: review each one before running it.

Loading voting…