Indico has a Cross-Site-Scripting during account creation
CVE-2024-45399GHSA-rrqf-w74j-24ff
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (indico 3.3.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI indico
- Affected
- < 3.3.4
- Fixed in
- 3.3.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rrqf-w74j-24ff lists affected ranges: PyPI indico >=0 <3.3.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rrqf-w74j-24ff lists affected ranges: PyPI indico >=0 <3.3.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-45399: 0.38% estimated exploitation activity in the next 30 days; percentile 32.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact There is a Cross-Site-Scripting vulnerability during account creation when redirecting after the account has been successfully created. Exploitation requires the user to initiate the account creation process with a maliciously crafted link, and then finalize the signup process. Because of this, it can only target newly created (and thus unprivileged) Indico users so the benefits of exploiting it are very limited. Patches You should to update to Indico 3.3.4 as soon as possible. See the docs for instructions on how to update. Workarounds - If you build the Indico package yourself and cannot upgrade for some reason, you can simply update the flask-multipass dependency to =0.5.5 which fixes the vulnerability. You would do that by editing requirements.txt before building the package (see commit 7dcb573837), or possibly cherry-picking that particular commit. - Otherwise you could configure your web server to disallow requests containing a query string with a parameter that starts…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-rrqf-w74j-24ff
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-rrqf-w74j-24ff
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-45399 Advisory: Indico has a Cross-Site-Scripting during account creation IDs: CVE-2024-45399, GHSA-rrqf-w74j-24ff Record: https://patchnext.com/advisories/cve-2024-45399 (revision 3, source checked 26 Oct 2026, 13:18 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: indico 3.3.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI indico: affected < 3.3.4; fixed in 3.3.4 ## Suggested inspection (read-only) - `python -m pip show indico`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on indico. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rrqf-w74j-24ff (OSV record GHSA-rrqf-w74j-24ff lists affected ranges: PyPI indico >=0 <3.3.4 (fixed)) - Verified: https://github.com/advisories/GHSA-rrqf-w74j-24ff (GitHub-reviewed advisory GHSA-rrqf-w74j-24ff lists affected ranges: PyPI indico >=0 <3.3.4) Commands are suggestions: review each one before running it.
Loading voting…