DOM clobbering could escalate to Cross-site Scripting (XSS)
CVE-2024-45389GHSA-gprj-6m2f-j9hx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pagefind 1.1.1; pagefind 1.1.1; @pagefind/modular-ui 1.1.1; @pagefind/default-ui 1.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gprj-6m2f-j9hx lists affected ranges: npm pagefind >=0 =0 =0 =0 <1.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gprj-6m2f-j9hx lists affected ranges: npm pagefind >=0 =0 =0 =0 <1.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-45389: 0.42% estimated exploitation activity in the next 30 days; percentile 36.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Pagefind initializes its dynamic JavaScript and WebAssembly files relative to the location of the first script you load. This information is gathered by looking up the value of document.currentScript.src. It is possible to "clobber" this lookup with otherwise benign HTML on the page, for example: This will cause document.currentScript.src to resolve as an external domain, which will then be used by Pagefind to load dependencies. This exploit would only work in the case that an attacker could inject HTML to your live, hosted, website. In these cases, this would act as a way to escalate the privilege available to an attacker. This assumes they have the ability to add some elements to the page (for example, img tags with a name attribute), but not others, as adding a script to the page would itself be the XSS vector. Pagefind has tightened this resolution by ensuring the source is loaded from a valid script element. There are no reports of this being exploited in the wild via Pagefind.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-gprj-6m2f-j9hx
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-gprj-6m2f-j9hx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-45389 Advisory: DOM clobbering could escalate to Cross-site Scripting (XSS) IDs: CVE-2024-45389, GHSA-gprj-6m2f-j9hx Record: https://patchnext.com/advisories/cve-2024-45389 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pagefind 1.1.1; pagefind 1.1.1; @pagefind/modular-ui 1.1.1; @pagefind/default-ui 1.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm pagefind: affected < 1.1.1; fixed in 1.1.1 - crates.io pagefind: affected < 1.1.1; fixed in 1.1.1 - npm @pagefind/modular-ui: affected < 1.1.1; fixed in 1.1.1 - npm @pagefind/default-ui: affected < 1.1.1; fixed in 1.1.1 ## Suggested inspection (read-only) - `npm ls pagefind --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - crates.io pagefind: check the installed version with your package manager. - `npm ls @pagefind/modular-ui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @pagefind/default-ui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pagefind, @pagefind/modular-ui, @pagefind/default-ui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gprj-6m2f-j9hx (OSV record GHSA-gprj-6m2f-j9hx lists affected ranges: npm pagefind >=0 =0 =0 =0 <1.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-gprj-6m2f-j9hx (GitHub-reviewed advisory GHSA-gprj-6m2f-j9hx lists affected ranges: npm pagefind >=0 =0 =0 =0 <1.1.1) Commands are suggestions: review each one before running it.
Loading voting…