Skip to content

← Actionable
High, CVSS 7.7amended

path-to-regexp outputs backtracking regular expressions

CVE-2024-45296GHSA-37ch-88jc-xwx2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (path-to-regexp 8.0.0, 6.3.0, 3.3.0, 1.9.0, 0.1.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm path-to-regexp

    Affected
    >= 0.2.0, < 1.9.0< 0.1.10>= 7.0.0, < 8.0.0>= 2.0.0, < 3.3.0>= 4.0.0, < 6.3.0
    Fixed in
    1.9.0, 0.1.10, 8.0.0, 3.3.0, 6.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2024-45296: 0.93% estimated exploitation activity in the next 30 days; percentile 60.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
  • CVE-2026-4867: 0.52% estimated exploitation activity in the next 30 days; percentile 43.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A bad regular expression is generated any time you have two parameters within a single segment, separated by something that is not a period (`.`). For example, `/:a-:b`.

Patches For users of 0.1, upgrade to `0.1.10`. All other users should upgrade to `8.0.0`. These versions add backtrack protection when a custom regex pattern is not provided: - 0.1.10 - 1.9.0 - 3.3.0 - 6.3.0 They do not protect against vulnerable user supplied capture groups. Protecting against explicit user patterns is out of scope for old versions and not considered a vulnerability. Version 7.1.0 can enable `strict: true` and get an error when the regular expression might be…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  2. Revision 2 · amended ·

    Amended from osv record GHSA-9wv6-86v2-598j

  3. Revision 1 · created ·

    Published from osv record GHSA-37ch-88jc-xwx2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-45296

Advisory: path-to-regexp outputs backtracking regular expressions
IDs: CVE-2024-45296, GHSA-37ch-88jc-xwx2
Record: https://patchnext.com/advisories/cve-2024-45296 (revision 3, source checked 24 Oct 2026, 22:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: path-to-regexp 8.0.0, 6.3.0, 3.3.0, 1.9.0, 0.1.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm path-to-regexp: affected >= 0.2.0, < 1.9.0; < 0.1.10; >= 7.0.0, < 8.0.0; >= 2.0.0, < 3.3.0; >= 4.0.0, < 6.3.0; fixed in 1.9.0, 0.1.10, 8.0.0, 3.3.0, 6.3.0

## Suggested inspection (read-only)
- `npm ls path-to-regexp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on path-to-regexp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-37ch-88jc-xwx2 (OSV record GHSA-37ch-88jc-xwx2 lists affected ranges: npm path-to-regexp >=0 <0.1.13 (fixed))
- Verified: https://osv.dev/vulnerability/GHSA-9wv6-86v2-598j (OSV record GHSA-9wv6-86v2-598j lists affected ranges: npm path-to-regexp >=0.2.0 =0 =7.0.0 =2.0.0 =4.0.0 <6.3.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…