Skip to content

← Actionable
High, CVSS 8.3

PhpSpreadsheet allows absolute path traversal and Server-Side Request Forgery when opening XLSX file

CVE-2024-45290GHSA-5gpr-w2p5-6m37

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpoffice/phpexcel

    Affected
    <= 1.8.2
    Fixed in
    no fixed version recorded
  • Packagist phpoffice/phpspreadsheet

    Affected
    >= 2.2.0, < 2.3.0< 1.29.2>= 2.0.0, < 2.1.1
    Fixed in
    2.3.0, 1.29.2, 2.1.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2024-45290: 0.63% estimated exploitation activity in the next 30 days; percentile 50.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary It's possible for an attacker to construct an XLSX file which links media from external URLs. When opening the XLSX file, PhpSpreadsheet retrieves the image size and type by reading the file contents, if the provided path is a URL. By using specially crafted php://filter URLs an attacker can leak the contents of any file or URL. Note that this vulnerability is different from GHSA-w9xv-qf98-ccq4, and resides in a different component. Details When an XLSX file is opened, the XLSX reader calls setPath() with the path provided in the xl/drawings/rels/drawing1.xml.rels file in the XLSX archive: setPath() then reads the file in order to determine the file type and dimensions, if the path is a URL: It's important to note here, that filtervar considers also file:// and php:// URLs valid. The attacker can set the path to anything: The contents of the file are not made available for the attacker directly. However, using PHP filter URLs it's possible to construct an error oracle which…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5gpr-w2p5-6m37

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-45290

Advisory: PhpSpreadsheet allows absolute path traversal and Server-Side Request Forgery when opening XLSX file
IDs: CVE-2024-45290, GHSA-5gpr-w2p5-6m37
Record: https://patchnext.com/advisories/cve-2024-45290 (revision 1, source checked 26 Oct 2026, 14:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: phpoffice/phpspreadsheet 2.3.0, 2.1.1, 1.29.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpoffice/phpexcel: affected <= 1.8.2
- Packagist phpoffice/phpspreadsheet: affected >= 2.2.0, < 2.3.0; < 1.29.2; >= 2.0.0, < 2.1.1; fixed in 2.3.0, 1.29.2, 2.1.1

## Suggested inspection (read-only)
- Packagist phpoffice/phpexcel: check the installed version with your package manager.
- Packagist phpoffice/phpspreadsheet: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpoffice/phpexcel, phpoffice/phpspreadsheet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5gpr-w2p5-6m37 (GitHub-reviewed advisory GHSA-5gpr-w2p5-6m37 lists affected ranges: Packagist phpoffice/phpspreadsheet >=2.2.0 =0 =2.0.0 =0 <=1.8.2)

Commands are suggestions: review each one before running it.

Loading voting…