LlamaIndex includes an exec call for import {cls_name}
CVE-2024-45201GHSA-fxc2-8m62-m85x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (llama-index 0.10.38; llama-index-core 0.10.38), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI llama-index
- Affected
- < 0.10.38
- Fixed in
- 0.10.38
PyPI llama-index-core
- Affected
- < 0.10.38
- Fixed in
- 0.10.38
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fxc2-8m62-m85x lists affected ranges: PyPI llama-index-core >=0 <0.10.38 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2024-192 lists affected ranges: PyPI llama-index >=0 <0.10.38 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fxc2-8m62-m85x lists affected ranges: PyPI llama-index-core >=0 <0.10.38
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-45201: 0.53% estimated exploitation activity in the next 30 days; percentile 45.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in llamaindex before 0.10.38. download/integration.py includes an exec call for import {clsname}.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-fxc2-8m62-m85x
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record PYSEC-2024-192
- Revision 1 · created ·
Published from osv record GHSA-fxc2-8m62-m85x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-45201
Advisory: LlamaIndex includes an exec call for `import {cls_name}`
IDs: CVE-2024-45201, GHSA-fxc2-8m62-m85x
Record: https://patchnext.com/advisories/cve-2024-45201 (revision 4, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: llama-index 0.10.38; llama-index-core 0.10.38. A vendor fix does not mean a deployment is fixed.
## Affected components
- PyPI llama-index: affected < 0.10.38; fixed in 0.10.38
- PyPI llama-index-core: affected < 0.10.38; fixed in 0.10.38
## Suggested inspection (read-only)
- `python -m pip show llama-index`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show llama-index-core`: prints the installed version. Run with the environment that serves production active.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on llama-index, llama-index-core.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fxc2-8m62-m85x (OSV record GHSA-fxc2-8m62-m85x lists affected ranges: PyPI llama-index-core >=0 <0.10.38 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2024-192 (OSV record PYSEC-2024-192 lists affected ranges: PyPI llama-index >=0 <0.10.38 (fixed))
- Verified: https://github.com/advisories/GHSA-fxc2-8m62-m85x (GitHub-reviewed advisory GHSA-fxc2-8m62-m85x lists affected ranges: PyPI llama-index-core >=0 <0.10.38)
Commands are suggestions: review each one before running it.Loading voting…