Skip to content

← Actionable
Medium, CVSS 5.1

Magento Open Source Information Exposure vulnerability

CVE-2024-45134GHSA-4f89-5cwm-rm5g

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist magento/community-edition

    Affected
    >= 2.4.7-beta1, < 2.4.7-p3>= 2.4.6-p1, < 2.4.6-p8>= 2.4.5-p1, < 2.4.5-p10< 2.4.4-p11>= 2.4.7, <= 2.4.7>= 2.4.6, <= 2.4.6>= 2.4.5, <= 2.4.5>= 2.4.4, <= 2.4.4
    Fixed in
    2.4.5-p10, 2.4.4-p11, 2.4.6-p8, 2.4.7-p3

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-4f89-5cwm-rm5g lists affected ranges: Packagist magento/community-edition >=2.4.7-beta1 =2.4.6-p1 =2.4.5-p1 =0 =2.4.7 =2.4.6 =2.4.5 =2.4.4 <=2.4.4

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-45134: 0.63% estimated exploitation activity in the next 30 days; percentile 50.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Magento Open Source versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by an Information Exposure vulnerability that could result in a security feature bypass. An admin attacker could leverage this vulnerability to have a low impact on confidentiality which may aid in further attacks. Exploitation of this issue does not require user interaction.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4f89-5cwm-rm5g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-45134

Advisory: Magento Open Source Information Exposure vulnerability
IDs: CVE-2024-45134, GHSA-4f89-5cwm-rm5g
Record: https://patchnext.com/advisories/cve-2024-45134 (revision 1, source checked 26 Oct 2026, 14:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: magento/community-edition 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist magento/community-edition: affected >= 2.4.7-beta1, < 2.4.7-p3; >= 2.4.6-p1, < 2.4.6-p8; >= 2.4.5-p1, < 2.4.5-p10; < 2.4.4-p11; >= 2.4.7, <= 2.4.7; >= 2.4.6, <= 2.4.6; >= 2.4.5, <= 2.4.5; >= 2.4.4, <= 2.4.4; fixed in 2.4.5-p10, 2.4.4-p11, 2.4.6-p8, 2.4.7-p3

## Suggested inspection (read-only)
- Packagist magento/community-edition: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on magento/community-edition.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4f89-5cwm-rm5g (GitHub-reviewed advisory GHSA-4f89-5cwm-rm5g lists affected ranges: Packagist magento/community-edition >=2.4.7-beta1 =2.4.6-p1 =2.4.5-p1 =0 =2.4.7 =2.4.6 =2.4.5 =2.4.4 <=2.4.4)

Commands are suggestions: review each one before running it.

Loading voting…