Skip to content

← Actionable
Medium, CVSS 5.3

PhpSpreadsheet has an Unauthenticated Cross-Site-Scripting (XSS) in sample file

CVE-2024-45060GHSA-v66g-p9x6-v98p

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpoffice/phpexcel

    Affected
    <= 1.8.2
    Fixed in
    no fixed version recorded
  • Packagist phpoffice/phpspreadsheet

    Affected
    >= 2.2.0, < 2.3.0< 1.29.2>= 2.0.0, < 2.1.1
    Fixed in
    2.3.0, 1.29.2, 2.1.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2024-45060: 0.51% estimated exploitation activity in the next 30 days; percentile 43.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary One of the sample scripts in PhpSpreadsheet is susceptible to a cross-site scripting (XSS) vulnerability due to improper handling of input where a number is expected leading to formula injection. Details The following code in 45Quadraticequationsolver.php concatenates the user supplied parameters directly into spreadsheet formulas. This allows an attacker to take control over the formula and output unsanitized data into the page, resulting in JavaScript execution. PoC 1. Access 45Quadraticequationsolver.php in a browser 2. Enter any valid values for for b and c, and enter the following for a 3. Press submit and observe that JavaScript is executed. Impact The impact of this vulnerability on the project is expected to be relatively low since these are sample files that should not be included when the library is used properly (e.g., through composer). However, at least two instances of popular WordPress plugins have unintentionally exposed this file by including the entire git…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v66g-p9x6-v98p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-45060

Advisory: PhpSpreadsheet has an Unauthenticated Cross-Site-Scripting (XSS) in sample file
IDs: CVE-2024-45060, GHSA-v66g-p9x6-v98p
Record: https://patchnext.com/advisories/cve-2024-45060 (revision 1, source checked 26 Oct 2026, 14:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: phpoffice/phpspreadsheet 2.3.0, 2.1.1, 1.29.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpoffice/phpexcel: affected <= 1.8.2
- Packagist phpoffice/phpspreadsheet: affected >= 2.2.0, < 2.3.0; < 1.29.2; >= 2.0.0, < 2.1.1; fixed in 2.3.0, 1.29.2, 2.1.1

## Suggested inspection (read-only)
- Packagist phpoffice/phpexcel: check the installed version with your package manager.
- Packagist phpoffice/phpspreadsheet: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpoffice/phpexcel, phpoffice/phpspreadsheet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v66g-p9x6-v98p (GitHub-reviewed advisory GHSA-v66g-p9x6-v98p lists affected ranges: Packagist phpoffice/phpspreadsheet >=2.2.0 =0 =2.0.0 =0 <=1.8.2)

Commands are suggestions: review each one before running it.

Loading voting…