Skip to content

← Actionable
High, CVSS 8.6amended

Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine

CVE-2024-45053GHSA-c34r-238x-f7qx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ethyca-fides 2.44.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-45053: 1.34% estimated exploitation activity in the next 30 days; percentile 71.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Email Templating feature uses Jinja2 without proper input sanitization or rendering environment restrictions, allowing for Server-Side Template Injection that grants Remote Code Execution to privileged users. A privileged user refers to an Admin UI user with the default Owner or Contributor role, who can escalate their access and execute code on the underlying Fides Webserver container where the Jinja template rendering function is executed. Details The application enables the creation of message templates that are sent via email to Fides Privacy Center users (data subjects) who raise privacy requests such as data subject access requests or consent management requests via the Privacy Center. These emails are triggered at various points in the request processing flow, for example when a request is denied or approved. The messages are defined using Jinja2 templates, allowing the use of statement and expression directives to craft more complex messages that include dynamic…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-c34r-238x-f7qx

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-c34r-238x-f7qx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-45053

Advisory: Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine
IDs: CVE-2024-45053, GHSA-c34r-238x-f7qx
Record: https://patchnext.com/advisories/cve-2024-45053 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ethyca-fides 2.44.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ethyca-fides: affected >= 2.19.0, < 2.44.0; fixed in 2.44.0

## Suggested inspection (read-only)
- `python -m pip show ethyca-fides`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ethyca-fides.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c34r-238x-f7qx (OSV record GHSA-c34r-238x-f7qx lists affected ranges: PyPI ethyca-fides >=2.19.0 <2.44.0 (fixed))
- Verified: https://github.com/advisories/GHSA-c34r-238x-f7qx (GitHub-reviewed advisory GHSA-c34r-238x-f7qx lists affected ranges: PyPI ethyca-fides >=2.19.0 <2.44.0)

Commands are suggestions: review each one before running it.

Loading voting…