Timing-Based Username Enumeration Vulnerability in Fides Webserver Authentication
CVE-2024-45052GHSA-2h46-8gf5-fmxv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ethyca-fides 2.44.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ethyca-fides
- Affected
- < 2.44.0
- Fixed in
- 2.44.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2h46-8gf5-fmxv lists affected ranges: PyPI ethyca-fides >=0 <2.44.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2h46-8gf5-fmxv lists affected ranges: PyPI ethyca-fides >=0 <2.44.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2024-45052: 0.56% estimated exploitation activity in the next 30 days; percentile 46.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A timing-based username enumeration vulnerability has been identified in Fides Webserver authentication. This vulnerability allows an unauthenticated attacker to determine the existence of valid usernames by analyzing the time it takes for the server to respond to login requests. The discrepancy in response times between valid and invalid usernames can be leveraged to enumerate users on the system. Impact This vulnerability enables a timing-based username enumeration attack. An attacker can systematically guess and verify which usernames are valid by measuring the server's response time to authentication requests. This information can be used to conduct further attacks on authentication such as password brute-forcing and credential stuffing. Patches The vulnerability has been patched in Fides version 2.44.0. Users are advised to upgrade to this version or later to secure their systems against this threat. Workarounds There are no workarounds. Proof of Concept 1. Create a valid user…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2h46-8gf5-fmxv
- Revision 1 · created ·
Published from osv record GHSA-2h46-8gf5-fmxv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-45052 Advisory: Timing-Based Username Enumeration Vulnerability in Fides Webserver Authentication IDs: CVE-2024-45052, GHSA-2h46-8gf5-fmxv Record: https://patchnext.com/advisories/cve-2024-45052 (revision 2, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ethyca-fides 2.44.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ethyca-fides: affected < 2.44.0; fixed in 2.44.0 ## Suggested inspection (read-only) - `python -m pip show ethyca-fides`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ethyca-fides. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2h46-8gf5-fmxv (OSV record GHSA-2h46-8gf5-fmxv lists affected ranges: PyPI ethyca-fides >=0 <2.44.0 (fixed)) - Verified: https://github.com/advisories/GHSA-2h46-8gf5-fmxv (GitHub-reviewed advisory GHSA-2h46-8gf5-fmxv lists affected ranges: PyPI ethyca-fides >=0 <2.44.0) Commands are suggestions: review each one before running it.
Loading voting…