XXE in PHPSpreadsheet encoding is returned
CVE-2024-45048GHSA-ghg6-32f9-2jp7
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpoffice/phpexcel
- Affected
- <= 1.8.2
- Fixed in
- no fixed version recorded
Packagist phpoffice/phpspreadsheet
- Affected
- < 1.29.1>= 2.2.0, < 2.2.1>= 2.0.0, < 2.1.1
- Fixed in
- 1.29.1, 2.1.1, 2.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ghg6-32f9-2jp7 lists affected ranges: Packagist phpoffice/phpspreadsheet >=0 =2.2.0 =2.0.0 =0 <=1.8.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-45048: 0.60% estimated exploitation activity in the next 30 days; percentile 48.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Bypassing the filter allows a XXE-attack. Which is turn allows attacker to obtain contents of local files, even if error reporting muted by @ symbol. (LFI-attack) Details Check $pattern = '/encoding="(.?)"/'; easy to bypass. Just use a single quote symbol '. So payload looks like this: If you add this header to any XML file into xlsx-formatted file, such as sharedStrings.xml file, then xxe will execute. PoC 1) Create simple xlsx file 2) Rename xlsx to zip 3) Go to the zip and open the xl/sharedStrings.xml file in edit mode. 4) Replace <?xml version="1.0" encoding="UTF-8" standalone="yes"? to 5) Save sharedStrings.xml file and rename zip back to xlsx. 6) Use minimal php code that simply opens this xlsx file: 7) You will receive the request to your http://%webhook%/file.dtd 8) Dont't forget that you can use php-wrappers into xxe, some php:// wrapper payload allows fetch local files. Impact Read local files
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-ghg6-32f9-2jp7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-45048 Advisory: XXE in PHPSpreadsheet encoding is returned IDs: CVE-2024-45048, GHSA-ghg6-32f9-2jp7 Record: https://patchnext.com/advisories/cve-2024-45048 (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: phpoffice/phpspreadsheet 2.2.1, 2.1.1, 1.29.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpoffice/phpexcel: affected <= 1.8.2 - Packagist phpoffice/phpspreadsheet: affected < 1.29.1; >= 2.2.0, < 2.2.1; >= 2.0.0, < 2.1.1; fixed in 1.29.1, 2.1.1, 2.2.1 ## Suggested inspection (read-only) - Packagist phpoffice/phpexcel: check the installed version with your package manager. - Packagist phpoffice/phpspreadsheet: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpoffice/phpexcel, phpoffice/phpspreadsheet. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-ghg6-32f9-2jp7 (GitHub-reviewed advisory GHSA-ghg6-32f9-2jp7 lists affected ranges: Packagist phpoffice/phpspreadsheet >=0 =2.2.0 =2.0.0 =0 <=1.8.2) Commands are suggestions: review each one before running it.
Loading voting…