Skip to content

← Actionable
Medium, CVSS 5.1amended

Svelte has a potential mXSS vulnerability due to improper HTML escaping

CVE-2024-45047GHSA-8266-84wp-wv5c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (svelte 4.2.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm svelte

    Affected
    < 4.2.19
    Fixed in
    4.2.19

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2024-45047: 0.36% estimated exploitation activity in the next 30 days; percentile 30.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A potential XSS vulnerability exists in Svelte for versions prior to 4.2.19. Details Svelte improperly escapes HTML on server-side rendering. It converts strings according to the following rules: - If the string is an attribute value: - " - &quot; - & - &amp; - Other characters - No conversion - Otherwise: - < - &lt; - & - &amp; - Other characters - No conversion The assumption is that attributes will always stay as such, but in some situation the final DOM tree rendered on browsers is different from what Svelte expects on server-side rendering. This may be leveraged to perform XSS attacks. More specifically, this can occur when injecting malicious content into an attribute within a <noscript tag. PoC A vulnerable page (+page.svelte): If a user accesses the following URL, then, alert(123) will be executed. Impact XSS, when using an attribute within a noscript tag

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8266-84wp-wv5c

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-8266-84wp-wv5c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-45047

Advisory: Svelte has a potential mXSS vulnerability due to improper HTML escaping
IDs: CVE-2024-45047, GHSA-8266-84wp-wv5c
Record: https://patchnext.com/advisories/cve-2024-45047 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: svelte 4.2.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm svelte: affected < 4.2.19; fixed in 4.2.19

## Suggested inspection (read-only)
- `npm ls svelte --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on svelte.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8266-84wp-wv5c (OSV record GHSA-8266-84wp-wv5c lists affected ranges: npm svelte >=0 <4.2.19 (fixed))
- Verified: https://github.com/advisories/GHSA-8266-84wp-wv5c (GitHub-reviewed advisory GHSA-8266-84wp-wv5c lists affected ranges: npm svelte >=0 <4.2.19)

Commands are suggestions: review each one before running it.

Loading voting…