Skip to content

← Actionable
Medium, CVSS 4.8

PhpSpreadsheet HTML writer is vulnerable to Cross-Site Scripting via style information

CVE-2024-45046GHSA-wgmf-q9vr-vww6

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpoffice/phpexcel

    Affected
    <= 1.8.2
    Fixed in
    no fixed version recorded
  • Packagist phpoffice/phpspreadsheet

    Affected
    >= 2.0.0, < 2.1.0< 1.29.1
    Fixed in
    1.29.1, 2.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2024-45046: 0.42% estimated exploitation activity in the next 30 days; percentile 36.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary \PhpOffice\PhpSpreadsheet\Writer\Html doesn't sanitize spreadsheet styling information such as font names, allowing an attacker to inject arbitrary JavaScript on the page. PoC Example target script: Save this file in the same directory: book.xlsx Open index.php in a web browser. An alert should be displayed. Impact Full takeover of the session of users viewing spreadsheet files as HTML.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wgmf-q9vr-vww6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-45046

Advisory: PhpSpreadsheet HTML writer is vulnerable to Cross-Site Scripting via style information
IDs: CVE-2024-45046, GHSA-wgmf-q9vr-vww6
Record: https://patchnext.com/advisories/cve-2024-45046 (revision 1, source checked 26 Oct 2026, 14:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: phpoffice/phpspreadsheet 2.1.0, 1.29.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpoffice/phpexcel: affected <= 1.8.2
- Packagist phpoffice/phpspreadsheet: affected >= 2.0.0, < 2.1.0; < 1.29.1; fixed in 1.29.1, 2.1.0

## Suggested inspection (read-only)
- Packagist phpoffice/phpexcel: check the installed version with your package manager.
- Packagist phpoffice/phpspreadsheet: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpoffice/phpexcel, phpoffice/phpspreadsheet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wgmf-q9vr-vww6 (GitHub-reviewed advisory GHSA-wgmf-q9vr-vww6 lists affected ranges: Packagist phpoffice/phpspreadsheet >=2.0.0 =0 =0 <=1.8.2)

Commands are suggestions: review each one before running it.

Loading voting…