Skip to content

← Actionable
Medium, CVSS 5.9

Ory Kratos's setting required_aal highest_available does not properly respect code + mfa credentials

CVE-2024-45042GHSA-wc43-73w7-x2f5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/ory/kratos 1.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.9 · CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-45042: 0.33% estimated exploitation activity in the next 30 days; percentile 25.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Preconditions - The code login method is enabled with the passwordlessenabled flag set to true . - A 2FA method such as totp is enabled. - requiredaal of the whomai check or the settings flow is set to highestavailable. AAL stands for Authenticator Assurance Levels and can range from 0 (no factor) to 2 (two factors). - A user uses the code method as the only login method available. They do not have a password or any other first factor credential enabled. - The user has 2FA enabled. - The user’s availableaal is incorrectly stored in the database as aal1 or aal0 or NULL. - A user signs in using the code method, but does not complete the 2FA challenge. Example server configuration Below you will find an vulnerable example configuration. Keep in mind that, for the account to be vulnerable, the account must have no first factor except the code method enabled plus a second factor. Impact Given the preconditions, the highestavailable setting will incorrectly assume that the identity’s…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wc43-73w7-x2f5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-45042

Advisory: Ory Kratos's setting required_aal `highest_available` does not properly respect code + mfa credentials
IDs: CVE-2024-45042, GHSA-wc43-73w7-x2f5
Record: https://patchnext.com/advisories/cve-2024-45042 (revision 1, source checked 26 Oct 2026, 15:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/ory/kratos 1.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/ory/kratos: affected <= 1.2.0; fixed in 1.3.0

## Suggested inspection (read-only)
- Go github.com/ory/kratos: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/ory/kratos.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wc43-73w7-x2f5 (GitHub-reviewed advisory GHSA-wc43-73w7-x2f5 lists affected ranges: Go github.com/ory/kratos >=0 <=1.2.0)

Commands are suggestions: review each one before running it.

Loading voting…