uptrace pgdriver SQL injection vulnerability
CVE-2024-44906GHSA-h4h6-vccr-44h2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/uptrace/bun/driver/pgdriver 1.2.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/uptrace/bun/driver/pgdriver
- Affected
- < 1.2.15
- Fixed in
- 1.2.15
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h4h6-vccr-44h2 lists affected ranges: Go github.com/uptrace/bun/driver/pgdriver >=0 <1.2.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- EPSS
- CVE-2024-44906: 0.39% estimated exploitation activity in the next 30 days; percentile 33.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
uptrace pgdriver v1.2.1 was discovered to contain a SQL injection vulnerability via the appendArg function in /pgdriver/format.go. The maintainer has stated that the issue is fixed in v1.2.15.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h4h6-vccr-44h2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-44906 Advisory: uptrace pgdriver SQL injection vulnerability IDs: CVE-2024-44906, GHSA-h4h6-vccr-44h2 Record: https://patchnext.com/advisories/cve-2024-44906 (revision 1, source checked 26 Oct 2026, 15:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/uptrace/bun/driver/pgdriver 1.2.15. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/uptrace/bun/driver/pgdriver: affected < 1.2.15; fixed in 1.2.15 ## Suggested inspection (read-only) - Go github.com/uptrace/bun/driver/pgdriver: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/uptrace/bun/driver/pgdriver. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h4h6-vccr-44h2 (GitHub-reviewed advisory GHSA-h4h6-vccr-44h2 lists affected ranges: Go github.com/uptrace/bun/driver/pgdriver >=0 <1.2.15) Commands are suggestions: review each one before running it.
Loading voting…