Improper line feed handling in zenml
CVE-2024-4460GHSA-7gjr-hcc3-xfr4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zenml 0.57.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI zenml
- Affected
- < 0.57.1
- Fixed in
- 0.57.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7gjr-hcc3-xfr4 lists affected ranges: PyPI zenml >=0 <0.57.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7gjr-hcc3-xfr4 lists affected ranges: PyPI zenml >=0 <0.57.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
A denial of service (DoS) vulnerability exists in zenml-io/zenml version 0.56.3 due to improper handling of line feed (\n) characters in component names. When a low-privileged user adds a component through the API endpoint api/v1/workspaces/default/components with a name containing a \n character, it leads to uncontrolled resource consumption. This vulnerability results in the inability of users to add new components in certain categories (e.g., 'Image Builder') and to register new stacks through the UI, thereby degrading the user experience and potentially rendering the ZenML Dashboard unusable. The issue does not affect component addition through the Web UI, as \n characters are properly escaped in that context. The vulnerability was tested on ZenML running in Docker, and it was observed in both Firefox and Chrome browsers.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7gjr-hcc3-xfr4
- Revision 1 · created ·
Published from osv record GHSA-7gjr-hcc3-xfr4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-4460 Advisory: Improper line feed handling in zenml IDs: CVE-2024-4460, GHSA-7gjr-hcc3-xfr4 Record: https://patchnext.com/advisories/cve-2024-4460 (revision 2, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zenml 0.57.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI zenml: affected < 0.57.1; fixed in 0.57.1 ## Suggested inspection (read-only) - `python -m pip show zenml`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zenml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7gjr-hcc3-xfr4 (OSV record GHSA-7gjr-hcc3-xfr4 lists affected ranges: PyPI zenml >=0 <0.57.1 (fixed)) - Verified: https://github.com/advisories/GHSA-7gjr-hcc3-xfr4 (GitHub-reviewed advisory GHSA-7gjr-hcc3-xfr4 lists affected ranges: PyPI zenml >=0 <0.57.1) Commands are suggestions: review each one before running it.
Loading voting…