TastyIgniter Has an Incorrect Access Control Vulnerability via invoice() Function
CVE-2024-44313GHSA-gg2f-r4jh-vpmh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tastyigniter/tastyigniter 4.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist tastyigniter/tastyigniter
- Affected
- < 4.0.0
- Fixed in
- 4.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gg2f-r4jh-vpmh lists affected ranges: Packagist tastyigniter/tastyigniter >=0 <4.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2024-44313: 0.74% estimated exploitation activity in the next 30 days; percentile 54.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the invoice() function within Orders.php which allows unauthorized users to access and generate invoices due to missing permission checks.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gg2f-r4jh-vpmh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-44313 Advisory: TastyIgniter Has an Incorrect Access Control Vulnerability via `invoice()` Function IDs: CVE-2024-44313, GHSA-gg2f-r4jh-vpmh Record: https://patchnext.com/advisories/cve-2024-44313 (revision 1, source checked 26 Oct 2026, 14:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tastyigniter/tastyigniter 4.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist tastyigniter/tastyigniter: affected < 4.0.0; fixed in 4.0.0 ## Suggested inspection (read-only) - Packagist tastyigniter/tastyigniter: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tastyigniter/tastyigniter. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gg2f-r4jh-vpmh (GitHub-reviewed advisory GHSA-gg2f-r4jh-vpmh lists affected ranges: Packagist tastyigniter/tastyigniter >=0 <4.0.0) Commands are suggestions: review each one before running it.
Loading voting…