Skip to content

← Actionable
High, CVSS 8.8amended

HTML injection in Jupyter Notebook and JupyterLab leading to DOM Clobbering

CVE-2024-43805GHSA-9q39-rmj3-p4r2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyterlab 4.2.5, 3.6.8; notebook 7.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI jupyterlab

    Affected
    <= 3.6.7>= 4.0.0, <= 4.2.4
    Fixed in
    4.2.5, 3.6.8
  • PyPI notebook

    Affected
    >= 7.0.0, <= 7.2.1
    Fixed in
    7.2.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-43805: 0.40% estimated exploitation activity in the next 30 days; percentile 34.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The vulnerability depends on user interaction by opening a malicious notebook with Markdown cells, or Markdown file using JupyterLab preview feature. A malicious user can access any data that the attacked user has access to as well as perform arbitrary requests acting as the attacked user. Patches JupyterLab v3.6.8, v4.2.5 and Jupyter Notebook v7.2.2 were patched. Workarounds There is no workaround for the underlying DOM Clobbering susceptibility. However, select plugins can be disabled on deployments which cannot update in a timely fashion to minimise the risk. These are: - @jupyterlab/mathjax-extension:plugin - users will loose ability to preview mathematical equations - @jupyterlab/markdownviewer-extension:plugin - users will loose ability to open Markdown previews - @jupyterlab/mathjax2-extension:plugin (if installed with optional jupyterlab-mathjax2 package) - an older version of the mathjax plugin for JupyterLab 4.x To disable these extensions run: To confirm that the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9q39-rmj3-p4r2

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-9q39-rmj3-p4r2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-43805

Advisory: HTML injection in Jupyter Notebook and JupyterLab leading to DOM Clobbering
IDs: CVE-2024-43805, GHSA-9q39-rmj3-p4r2
Record: https://patchnext.com/advisories/cve-2024-43805 (revision 3, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jupyterlab 4.2.5, 3.6.8; notebook 7.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI jupyterlab: affected <= 3.6.7; >= 4.0.0, <= 4.2.4; fixed in 4.2.5, 3.6.8
- PyPI notebook: affected >= 7.0.0, <= 7.2.1; fixed in 7.2.2

## Suggested inspection (read-only)
- `python -m pip show jupyterlab`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show notebook`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jupyterlab, notebook.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9q39-rmj3-p4r2 (OSV record GHSA-9q39-rmj3-p4r2 lists affected ranges: PyPI jupyterlab >=0 =4.0.0 =7.0.0 <7.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-9q39-rmj3-p4r2 (GitHub-reviewed advisory GHSA-9q39-rmj3-p4r2 lists affected ranges: PyPI jupyterlab >=0 =4.0.0 =7.0.0 <=7.2.1)

Commands are suggestions: review each one before running it.

Loading voting…