Webpack's AutoPublicPathRuntimeModule has a DOM Clobbering Gadget that leads to XSS
CVE-2024-43788GHSA-4vvj-4cpr-p986
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (webpack 5.94.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm webpack
- Affected
- >= 5.0.0-alpha.0, < 5.94.0
- Fixed in
- 5.94.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4vvj-4cpr-p986 lists affected ranges: npm webpack >=5.0.0-alpha.0 <5.94.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4vvj-4cpr-p986 lists affected ranges: npm webpack >=5.0.0-alpha.0 <5.94.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-43788: 0.96% estimated exploitation activity in the next 30 days; percentile 61.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary We discovered a DOM Clobbering vulnerability in Webpack’s AutoPublicPathRuntimeModule. The DOM Clobbering gadget in the module can lead to cross-site scripting (XSS) in web pages where scriptless attacker-controlled HTML elements (e.g., an img tag with an unsanitized name attribute) are present. We found the real-world exploitation of this gadget in the Canvas LMS which allows XSS attack happens through an javascript code compiled by Webpack (the vulnerable part is from Webpack). We believe this is a severe issue. If Webpack’s code is not resilient to DOM Clobbering attacks, it could lead to significant security vulnerabilities in any web application using Webpack-compiled code. Details Backgrounds DOM Clobbering is a type of code-reuse attack where the attacker first embeds a piece of non-script, seemingly benign HTML markups in the webpage (e.g. through a post or comment) and leverages the gadgets (pieces of js code) living in the existing javascript code to transform it…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4vvj-4cpr-p986
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-4vvj-4cpr-p986
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-43788 Advisory: Webpack's AutoPublicPathRuntimeModule has a DOM Clobbering Gadget that leads to XSS IDs: CVE-2024-43788, GHSA-4vvj-4cpr-p986 Record: https://patchnext.com/advisories/cve-2024-43788 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: webpack 5.94.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm webpack: affected >= 5.0.0-alpha.0, < 5.94.0; fixed in 5.94.0 ## Suggested inspection (read-only) - `npm ls webpack --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on webpack. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4vvj-4cpr-p986 (OSV record GHSA-4vvj-4cpr-p986 lists affected ranges: npm webpack >=5.0.0-alpha.0 <5.94.0 (fixed)) - Verified: https://github.com/advisories/GHSA-4vvj-4cpr-p986 (GitHub-reviewed advisory GHSA-4vvj-4cpr-p986 lists affected ranges: npm webpack >=5.0.0-alpha.0 <5.94.0) Commands are suggestions: review each one before running it.
Loading voting…