PDF.js vulnerable to arbitrary JavaScript execution upon opening a malicious PDF
CVE-2024-4367GHSA-wgrm-67xf-hhpq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pdfjs-dist 4.2.67), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm pdfjs-dist
- Affected
- <= 4.1.392
- Fixed in
- 4.2.67
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wgrm-67xf-hhpq lists affected ranges: npm pdfjs-dist >=0 <4.2.67 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wgrm-67xf-hhpq lists affected ranges: npm pdfjs-dist >=0 <=4.1.392
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2024-4367: 70.66% estimated exploitation activity in the next 30 days; percentile 99.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact If pdf.js is used to load a malicious PDF, and PDF.js is configured with isEvalSupported set to true (which is the default value), unrestricted attacker-controlled JavaScript will be executed in the context of the hosting domain. Patches The patch removes the use of eval: https://github.com/mozilla/pdf.js/pull/18015 Workarounds Set the option isEvalSupported to false. References https://bugzilla.mozilla.org/showbug.cgi?id=1893645
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wgrm-67xf-hhpq
- Revision 1 · created ·
Published from osv record GHSA-wgrm-67xf-hhpq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-4367 Advisory: PDF.js vulnerable to arbitrary JavaScript execution upon opening a malicious PDF IDs: CVE-2024-4367, GHSA-wgrm-67xf-hhpq Record: https://patchnext.com/advisories/cve-2024-4367 (revision 2, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pdfjs-dist 4.2.67. A vendor fix does not mean a deployment is fixed. ## Affected components - npm pdfjs-dist: affected <= 4.1.392; fixed in 4.2.67 ## Suggested inspection (read-only) - `npm ls pdfjs-dist --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pdfjs-dist. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wgrm-67xf-hhpq (OSV record GHSA-wgrm-67xf-hhpq lists affected ranges: npm pdfjs-dist >=0 <4.2.67 (fixed)) - Verified: https://github.com/advisories/GHSA-wgrm-67xf-hhpq (GitHub-reviewed advisory GHSA-wgrm-67xf-hhpq lists affected ranges: npm pdfjs-dist >=0 <=4.1.392) Commands are suggestions: review each one before running it.
Loading voting…