Decidim-Awesome has SQL injection in AdminAccountability
CVE-2024-43415GHSA-cxwf-qc32-375f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (decidim-decidim_awesome 0.11.2, 0.10.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems decidim-decidim_awesome
- Affected
- >= 0.9.1, < 0.10.3>= 0.11.0, < 0.11.2
- Fixed in
- 0.11.2, 0.10.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cxwf-qc32-375f lists affected ranges: RubyGems decidim-decidim_awesome >=0.9.1 =0.11.0 <0.11.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L/E:P · score source
- EPSS
- CVE-2024-43415: 0.68% estimated exploitation activity in the next 30 days; percentile 52.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Vulnerability type: CWE-89: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') Vendor: Decidim International Community Environment Has vendor confirmed: Yes Attack type: Remote Impact: Code Execution Escalation of Privileges Information Disclosure Affected component: A raw sql-statement that uses an interpolated variable exists in the adminroleactions method of the papertrail/version-model(app/models/decidim/decidimawesome/papertrailversion.rb). Attack vector: An attacker with admin permissions could manipulate database queries in order to read out the database, read files from the filesystem, write files from the filesystem. In the worst case, this could lead to remote code execution on the server. Description of the vulnerability for use in the CVE [ℹ] (https://cveproject.github.io/docs/content/key-details- phrasing.pdf) : An improper neutralization of special elements used in an SQL command in the papertrail/version- model of the decidimawesome-module…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cxwf-qc32-375f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-43415 Advisory: Decidim-Awesome has SQL injection in AdminAccountability IDs: CVE-2024-43415, GHSA-cxwf-qc32-375f Record: https://patchnext.com/advisories/cve-2024-43415 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: decidim-decidim_awesome 0.11.2, 0.10.3. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems decidim-decidim_awesome: affected >= 0.9.1, < 0.10.3; >= 0.11.0, < 0.11.2; fixed in 0.11.2, 0.10.3 ## Suggested inspection (read-only) - RubyGems decidim-decidim_awesome: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on decidim-decidim_awesome. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cxwf-qc32-375f (GitHub-reviewed advisory GHSA-cxwf-qc32-375f lists affected ranges: RubyGems decidim-decidim_awesome >=0.9.1 =0.11.0 <0.11.2) Commands are suggestions: review each one before running it.
Loading voting…