Skip to content

← Actionable
High, CVSS 8.7amended

Apollo Query Planner and Apollo Gateway may infinitely loop on sufficiently complex queries

CVE-2024-43414GHSA-fmj9-77q8-g6c4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apollo-router 1.52.1; @apollo/query-planner 2.8.5; @apollo/gateway 2.8.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-43414: 0.99% estimated exploitation activity in the next 30 days; percentile 62.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Instances of @apollo/query-planner =2.0.0 and <2.8.5 are impacted by a denial-of-service vulnerability. @apollo/gateway versions =2.0.0 and < 2.8.5 and Apollo Router <1.52.1 are also impacted through their use of @apollo/query-planner. If @apollo/query-planner is asked to plan a sufficiently complex query, it may loop infinitely and never complete. This results in unbounded memory consumption and either a crash or out-of-memory (OOM) termination. This issue can be triggered if you have at least one non-@key field that can be resolved by multiple subgraphs. To identify these shared fields, the schema for each subgraph must be reviewed. The mechanism to identify shared fields varies based on the version of Federation your subgraphs are using. You can check if your subgraphs are using Federation 1 or Federation 2 by reviewing their schemas. Federation 2 subgraph schemas will contain a @link directive referencing the version of Federation being used while Federation 1 subgraphs…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-fmj9-77q8-g6c4

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-fmj9-77q8-g6c4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-43414

Advisory: Apollo Query Planner and Apollo Gateway may infinitely loop on sufficiently complex queries
IDs: CVE-2024-43414, GHSA-fmj9-77q8-g6c4
Record: https://patchnext.com/advisories/cve-2024-43414 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apollo-router 1.52.1; @apollo/query-planner 2.8.5; @apollo/gateway 2.8.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io apollo-router: affected < 1.52.1; fixed in 1.52.1
- npm @apollo/query-planner: affected >= 2.0.0, < 2.8.5; fixed in 2.8.5
- npm @apollo/gateway: affected >= 2.0.0, < 2.8.5; fixed in 2.8.5

## Suggested inspection (read-only)
- crates.io apollo-router: check the installed version with your package manager.
- `npm ls @apollo/query-planner --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @apollo/gateway --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apollo-router, @apollo/query-planner, @apollo/gateway.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fmj9-77q8-g6c4 (OSV record GHSA-fmj9-77q8-g6c4 lists affected ranges: crates.io apollo-router >=0 =2.0.0 =2.0.0 <2.8.5 (fixed))
- Verified: https://github.com/advisories/GHSA-fmj9-77q8-g6c4 (GitHub-reviewed advisory GHSA-fmj9-77q8-g6c4 lists affected ranges: crates.io apollo-router >=0 =2.0.0 =2.0.0 <2.8.5)

Commands are suggestions: review each one before running it.

Loading voting…