CKEditor4 low-risk cross-site scripting (XSS) vulnerability linked to potential domain takeover
CVE-2024-43411GHSA-6v96-m24v-f58j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ckeditor4 4.25.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ckeditor4
- Affected
- >= 4.22.0, < 4.25.0
- Fixed in
- 4.25.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6v96-m24v-f58j lists affected ranges: npm ckeditor4 >=4.22.0 <4.25.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6v96-m24v-f58j lists affected ranges: npm ckeditor4 >=4.22.0 <4.25.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2024-43411: 0.43% estimated exploitation activity in the next 30 days; percentile 37.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected Packages The issue impacts only editor instances with enabled version notifications. Please note that this feature is disabled by default in all CKEditor 4 LTS versions. Therefore, if you use CKEditor 4 LTS, it is highly unlikely that you are affected by this vulnerability. If you are unsure, please contact us. Impact A theoretical vulnerability has been identified in CKEditor 4.22 (and above). In a highly unlikely scenario where an attacker gains control over the https://cke4.ckeditor.com domain, they could potentially execute an attack on CKEditor 4 instances. Although the vulnerability is purely hypothetical, we have addressed it in CKEditor 4.25.0-lts to ensure compliance with security best practices. Patches The issue has been recognized and patched. The fix is available in version 4.25.0-lts. For More Information If you have any questions or comments about this advisory, please email us at security@cksource.com.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6v96-m24v-f58j
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-6v96-m24v-f58j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-43411 Advisory: CKEditor4 low-risk cross-site scripting (XSS) vulnerability linked to potential domain takeover IDs: CVE-2024-43411, GHSA-6v96-m24v-f58j Record: https://patchnext.com/advisories/cve-2024-43411 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ckeditor4 4.25.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ckeditor4: affected >= 4.22.0, < 4.25.0; fixed in 4.25.0 ## Suggested inspection (read-only) - `npm ls ckeditor4 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ckeditor4. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6v96-m24v-f58j (OSV record GHSA-6v96-m24v-f58j lists affected ranges: npm ckeditor4 >=4.22.0 <4.25.0 (fixed)) - Verified: https://github.com/advisories/GHSA-6v96-m24v-f58j (GitHub-reviewed advisory GHSA-6v96-m24v-f58j lists affected ranges: npm ckeditor4 >=4.22.0 <4.25.0) Commands are suggestions: review each one before running it.
Loading voting…