Skip to content

← Actionable
Medium, CVSS 6.9amended

Ghost's improper authentication allows access to member information and actions

CVE-2024-43409GHSA-78x2-cwp9-5j42

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@tryghost/portal 2.39.0; ghost 5.89.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @tryghost/portal

    Affected
    >= 1.22.2, < 2.39.0
    Fixed in
    2.39.0
  • npm ghost

    Affected
    >= 4.46.0, < 5.89.5
    Fixed in
    5.89.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-43409: 0.32% estimated exploitation activity in the next 30 days; percentile 25.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Improper authentication on some endpoints used for member actions would allow an attacker to perform member-only actions, and read member information. Vulnerable versions This security vulnerability is present in Ghost v4.46.0-v5.89.5. Ghost(Pro) customers are automatically updated to fixed versions ahead of disclosure. If you're a self-hoster, please follow our update instructions. Patches v5.89.5 contains a fix for this issue. Workarounds Disable site membership in Ghost settings. For more information If you have any questions or comments about this advisory: Email us at security@ghost.org

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-78x2-cwp9-5j42

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-78x2-cwp9-5j42

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-43409

Advisory: Ghost's improper authentication allows access to member information and actions
IDs: CVE-2024-43409, GHSA-78x2-cwp9-5j42
Record: https://patchnext.com/advisories/cve-2024-43409 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @tryghost/portal 2.39.0; ghost 5.89.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @tryghost/portal: affected >= 1.22.2, < 2.39.0; fixed in 2.39.0
- npm ghost: affected >= 4.46.0, < 5.89.5; fixed in 5.89.5

## Suggested inspection (read-only)
- `npm ls @tryghost/portal --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @tryghost/portal, ghost.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-78x2-cwp9-5j42 (OSV record GHSA-78x2-cwp9-5j42 lists affected ranges: npm ghost >=4.46.0 =1.22.2 <2.39.0 (fixed))
- Verified: https://github.com/advisories/GHSA-78x2-cwp9-5j42 (GitHub-reviewed advisory GHSA-78x2-cwp9-5j42 lists affected ranges: npm ghost >=4.46.0 =1.22.2 <2.39.0)

Commands are suggestions: review each one before running it.

Loading voting…