XWiki Platform allows XSS through XClass name in string properties
CVE-2024-43400GHSA-wcg9-pgqv-xm5v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-oldcore 16.0.0, 15.10.6, 15.5.5, 14.10.21), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-oldcore
- Affected
- >= 1.1.2, < 14.10.21>= 15.0-rc-1, < 15.5.5>= 15.6-rc-1, < 15.10.6>= 16.0.0-rc-1, <= 16.0.0-rc-1
- Fixed in
- 14.10.21, 15.10.6, 15.5.5, 16.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wcg9-pgqv-xm5v lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=1.1.2 =15.0-rc-1 =15.6-rc-1 =16.0.0-rc-1 <=16.0.0-rc-1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2024-43400: 0.49% estimated exploitation activity in the next 30 days; percentile 42.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Is it possible for a user without Script or Programming rights to craft a URL pointing to a page with arbitrary JavaScript. This requires social engineer to trick a user to follow the URL. Reproduction steps 1. As a user without script or programming right, create a (non-terminal) document named " + alert(1) + " (the quotes need to be part of the name). 1. Edit the class. 1. Add a string property named "test". 1. Edit using the object editor and add an object of the created class 1. Get an admin to open <xwiki-server/xwiki/bin/view/%22%20%2B%20alert(1)%20%2B%20%22/?viewer=display&type=object&property=%22%20%2B%20alert(1)%20%2B%20%22.WebHome.test&mode=edit where <xwiki-server is the URL of your XWiki installation. Patches This has been patched in XWiki 14.10.21, 15.5.5, 15.10.6 and 16.0.0. Workarounds We're not aware of any workaround except upgrading. References - https://jira.xwiki.org/browse/XWIKI-21810 -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wcg9-pgqv-xm5v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-43400 Advisory: XWiki Platform allows XSS through XClass name in string properties IDs: CVE-2024-43400, GHSA-wcg9-pgqv-xm5v Record: https://patchnext.com/advisories/cve-2024-43400 (revision 1, source checked 26 Oct 2026, 16:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-oldcore 16.0.0, 15.10.6, 15.5.5, 14.10.21. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-oldcore: affected >= 1.1.2, < 14.10.21; >= 15.0-rc-1, < 15.5.5; >= 15.6-rc-1, < 15.10.6; >= 16.0.0-rc-1, <= 16.0.0-rc-1; fixed in 14.10.21, 15.10.6, 15.5.5, 16.0.0 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-oldcore: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-oldcore. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wcg9-pgqv-xm5v (GitHub-reviewed advisory GHSA-wcg9-pgqv-xm5v lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=1.1.2 =15.0-rc-1 =15.6-rc-1 =16.0.0-rc-1 <=16.0.0-rc-1) Commands are suggestions: review each one before running it.
Loading voting…