Skip to content

← Actionable
High, CVSS 8.6amended

Mobile Security Framework (MobSF) has a Zip Slip Vulnerability in .a Static Library Files

CVE-2024-43399GHSA-4hh3-vj32-gr6j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mobsf 4.0.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mobsf

    Affected
    <= 4.0.6
    Fixed in
    4.0.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-43399: 0.96% estimated exploitation activity in the next 30 days; percentile 61.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Upon reviewing the MobSF source code, I identified a flaw in the Static Libraries analysis section. Specifically, during the extraction of .a extension files, the measure intended to prevent Zip Slip attacks is improperly implemented. Since the implemented measure can be bypassed, the vulnerability allows an attacker to extract files to any desired location within the server running MobSF. Details Upon examining lines 183-192 of the mobsf/StaticAnalyzer/views/common/sharedfunc.py file, it is observed that there is a mitigation against Zip Slip attacks implemented as a.decode('utf-8', 'ignore').replace('../', '').replace('..\\', ''). However, this measure can be bypassed using sequences like ....//....//....//. Since the replace operation is not recursive, this sequence is transformed into ../../../ after the replace operation, allowing files to be written to upper directories. <img width="448" alt="image"…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4hh3-vj32-gr6j

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4hh3-vj32-gr6j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-43399

Advisory: Mobile Security Framework (MobSF) has a Zip Slip Vulnerability in .a Static Library Files
IDs: CVE-2024-43399, GHSA-4hh3-vj32-gr6j
Record: https://patchnext.com/advisories/cve-2024-43399 (revision 3, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mobsf 4.0.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mobsf: affected <= 4.0.6; fixed in 4.0.7

## Suggested inspection (read-only)
- `python -m pip show mobsf`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mobsf.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4hh3-vj32-gr6j (OSV record GHSA-4hh3-vj32-gr6j lists affected ranges: PyPI mobsf >=0 <4.0.7 (fixed))
- Verified: https://github.com/advisories/GHSA-4hh3-vj32-gr6j (GitHub-reviewed advisory GHSA-4hh3-vj32-gr6j lists affected ranges: PyPI mobsf >=0 <=4.0.6)

Commands are suggestions: review each one before running it.

Loading voting…