Skip to content

← Actionable
Medium, CVSS 5.3amended

Khoj Vulnerable to Stored Cross-site Scripting In Automate (Preview feature)

CVE-2024-43396GHSA-cf72-vg59-4j4h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (khoj 1.15.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI khoj

    Affected
    < 1.15.0
    Fixed in
    1.15.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2024-43396: 0.55% estimated exploitation activity in the next 30 days; percentile 46.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Automation feature allows a user to insert arbitrary HTML inside the task instructions, resulting in a Stored XSS. Details The q parameter for the /api/automation endpoint does not get correctly sanitized when rendered on the page, resulting in the ability of users to inject arbitrary HTML/JS. PoC Impact Stored XSS: Fix - Added a Content Security Policy to all config pages on the web client, including the automation page - Used DOM scripting to construct all components on the config pages, including the automation page

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cf72-vg59-4j4h

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-cf72-vg59-4j4h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-43396

Advisory: Khoj Vulnerable to Stored Cross-site Scripting In Automate (Preview feature)
IDs: CVE-2024-43396, GHSA-cf72-vg59-4j4h
Record: https://patchnext.com/advisories/cve-2024-43396 (revision 3, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: khoj 1.15.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI khoj: affected < 1.15.0; fixed in 1.15.0

## Suggested inspection (read-only)
- `python -m pip show khoj`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on khoj.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cf72-vg59-4j4h (OSV record GHSA-cf72-vg59-4j4h lists affected ranges: PyPI khoj >=0 <1.15.0 (fixed))
- Verified: https://github.com/advisories/GHSA-cf72-vg59-4j4h (GitHub-reviewed advisory GHSA-cf72-vg59-4j4h lists affected ranges: PyPI khoj >=0 <1.15.0)

Commands are suggestions: review each one before running it.

Loading voting…