Skip to content

← Actionable
High, CVSS 8.6

Apache Lucene.Net.Replicator Deserialization of Untrusted Data vulnerability

CVE-2024-43383GHSA-2qw8-ppr5-m96c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lucene.net.replicator 4.8.0-beta00017), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-43383: 1.19% estimated exploitation activity in the next 30 days; percentile 68.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Deserialization of Untrusted Data vulnerability in Apache Lucene.Net.Replicator. This issue affects Apache Lucene.NET's Replicator library: from 4.8.0-beta00005 through 4.8.0-beta00016. An attacker that can intercept traffic between a replication client and server, or control the target replication node URL, can provide a specially-crafted JSON response that is deserialized as an attacker-provided exception type. This can result in remote code execution or other potential unauthorized access. Users are recommended to upgrade to version 4.8.0-beta00017, which fixes the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2qw8-ppr5-m96c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-43383

Advisory: Apache Lucene.Net.Replicator Deserialization of Untrusted Data vulnerability
IDs: CVE-2024-43383, GHSA-2qw8-ppr5-m96c
Record: https://patchnext.com/advisories/cve-2024-43383 (revision 1, source checked 26 Oct 2026, 17:03 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lucene.net.replicator 4.8.0-beta00017. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet lucene.net.replicator: affected >= 4.8.0-beta00005, < 4.8.0-beta00017; fixed in 4.8.0-beta00017

## Suggested inspection (read-only)
- NuGet lucene.net.replicator: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lucene.net.replicator.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2qw8-ppr5-m96c (GitHub-reviewed advisory GHSA-2qw8-ppr5-m96c lists affected ranges: NuGet lucene.net.replicator >=4.8.0-beta00005 <4.8.0-beta00017)

Commands are suggestions: review each one before running it.

Loading voting…