Snowflake JDBC Security Advisory
CVE-2024-43382GHSA-f686-hw9c-xw9c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (net.snowflake:snowflake-jdbc 3.20.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven net.snowflake:snowflake-jdbc
- Affected
- >= 3.2.6, <= 3.19.1
- Fixed in
- 3.20.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f686-hw9c-xw9c lists affected ranges: Maven net.snowflake:snowflake-jdbc >=3.2.6 <=3.19.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2024-43382: 0.18% estimated exploitation activity in the next 30 days; percentile 7.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impacted Products Snowflake JDBC driver versions = 3.2.6 & <= 3.19.1 are affected. Introduction Snowflake recently identified an issue affecting JDBC drivers that can result in data being uploaded to an encrypted stage without the additional layer of protection provided by client side encryption. The issue, which affects only a subset of accounts hosted on Azure and GCP deployments (AWS deployments are not affected), manifests in instances where customers create a stage using a JDBC driver with the CLIENTENCRYPTIONKEYSIZE account parameter set to 256-bit rather than the default 128-bit. The data is still protected by TLS in transit and server side encryption at rest. This missed layer of the additional protection is not visible to the affected customers. Incorrect Security Setting Vulnerability Description Snowflake identified an incorrect security setting in Snowflake JDBC drivers. Snowflake has evaluated the severity of the issue and determined it was in medium range with a maximum…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f686-hw9c-xw9c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-43382 Advisory: Snowflake JDBC Security Advisory IDs: CVE-2024-43382, GHSA-f686-hw9c-xw9c Record: https://patchnext.com/advisories/cve-2024-43382 (revision 1, source checked 26 Oct 2026, 16:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: net.snowflake:snowflake-jdbc 3.20.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven net.snowflake:snowflake-jdbc: affected >= 3.2.6, <= 3.19.1; fixed in 3.20.0 ## Suggested inspection (read-only) - Maven net.snowflake:snowflake-jdbc: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on net.snowflake:snowflake-jdbc. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f686-hw9c-xw9c (GitHub-reviewed advisory GHSA-f686-hw9c-xw9c lists affected ranges: Maven net.snowflake:snowflake-jdbc >=3.2.6 <=3.19.1) Commands are suggestions: review each one before running it.
Loading voting…