webcrack has an Arbitrary File Write Vulnerability on Windows when Parsing and Saving a Malicious Bundle
CVE-2024-43373GHSA-ccqh-278p-xq6w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (webcrack 2.14.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm webcrack
- Affected
- <= 2.14.0
- Fixed in
- 2.14.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-ccqh-278p-xq6w lists affected ranges: npm webcrack >=0 <2.14.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ccqh-278p-xq6w lists affected ranges: npm webcrack >=0 <=2.14.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.2 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:H/SA:L · score source
- EPSS
- CVE-2024-43373: 0.45% estimated exploitation activity in the next 30 days; percentile 38.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An arbitrary file write vulnerability exists in the webcrack module when processing specifically crafted malicious code on Windows systems. This vulnerability is triggered when using the unpack bundles feature in conjunction with the saving feature. If a module name includes a path traversal sequence with Windows path separators, an attacker can exploit this to overwrite files on the host system. Details Source: packages/webcrack/src/unpack/bundle.ts#L79 In this code, the application explicitly relies on the POSIX version of path utilities (dirname, join, normalize) from Node.js. However, the vulnerability arises because the POSIX version of the normalize function does not recognize \ as a path separator. As a result, on Windows systems, the path traversal check fails, allowing an attacker to write files to unintended locations. PoC The following proof of concept demonstrates how this vulnerability can be exploited to overwrite and hijack the debug module in Node.js:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-ccqh-278p-xq6w
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-ccqh-278p-xq6w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-43373 Advisory: webcrack has an Arbitrary File Write Vulnerability on Windows when Parsing and Saving a Malicious Bundle IDs: CVE-2024-43373, GHSA-ccqh-278p-xq6w Record: https://patchnext.com/advisories/cve-2024-43373 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: webcrack 2.14.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm webcrack: affected <= 2.14.0; fixed in 2.14.1 ## Suggested inspection (read-only) - `npm ls webcrack --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on webcrack. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-ccqh-278p-xq6w (OSV record GHSA-ccqh-278p-xq6w lists affected ranges: npm webcrack >=0 <2.14.1 (fixed)) - Verified: https://github.com/advisories/GHSA-ccqh-278p-xq6w (GitHub-reviewed advisory GHSA-ccqh-278p-xq6w lists affected ranges: npm webcrack >=0 <=2.14.0) Commands are suggestions: review each one before running it.
Loading voting…