Skip to content

← Actionable
Medium, CVSS 6.8amended

Potential access to sensitive URLs via CKAN extensions (SSRF)

CVE-2024-43371GHSA-g9ph-j5vj-f8wm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ckan 2.10.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ckan

    Affected
    < 2.10.5
    Fixed in
    2.10.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-43371: 0.37% estimated exploitation activity in the next 30 days; percentile 30.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact There are a number of CKAN plugins, including XLoader, DataPusher, Resource proxy and ckanext-archiver, that work by downloading the contents of local or remote files in order to perform some actions with their contents (e.g. pushing to the DataStore, streaming contents or saving a local copy). All of them use the resource URL, and there are currently no checks to limit what URLs can be requested. This means that a malicious (or unaware) user can create a resource with a URL pointing to a place where they should not have access in order for one of the previous tools to retrieve it (known as a Server Side Request Forgery). Patches and Workarounds Users wanting to protect against these kinds of attacks can use one or a combination of the following approaches: Use a separate HTTP proxy like Squid that can be used to allow / disallow IPs, domains etc as needed, and make CKAN extensions aware of this setting via the ckan.downloadproxy config option. Implement custom firewall rules…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-g9ph-j5vj-f8wm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-g9ph-j5vj-f8wm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-43371

Advisory: Potential access to sensitive URLs via CKAN extensions (SSRF)
IDs: CVE-2024-43371, GHSA-g9ph-j5vj-f8wm
Record: https://patchnext.com/advisories/cve-2024-43371 (revision 3, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ckan 2.10.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ckan: affected < 2.10.5; fixed in 2.10.5

## Suggested inspection (read-only)
- `python -m pip show ckan`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ckan.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g9ph-j5vj-f8wm (OSV record GHSA-g9ph-j5vj-f8wm lists affected ranges: PyPI ckan >=0 <2.10.5 (fixed))
- Verified: https://github.com/advisories/GHSA-g9ph-j5vj-f8wm (GitHub-reviewed advisory GHSA-g9ph-j5vj-f8wm lists affected ranges: PyPI ckan >=0 <2.10.5)

Commands are suggestions: review each one before running it.

Loading voting…