Trix has a cross-site Scripting vulnerability on copy & paste
CVE-2024-43368GHSA-qm2q-9f3q-2vcv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (trix 2.1.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm trix
- Affected
- < 2.1.4
- Fixed in
- 2.1.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qm2q-9f3q-2vcv lists affected ranges: npm trix >=0 <2.1.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qm2q-9f3q-2vcv lists affected ranges: npm trix >=0 <2.1.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
- EPSS
- CVE-2024-43368: 0.52% estimated exploitation activity in the next 30 days; percentile 44.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Trix editor, versions prior to 2.1.4, is vulnerable to XSS when pasting malicious code. This vulnerability is a bypass of the fix put in place for https://github.com/basecamp/trix/security/advisories/GHSA-qjqp-xr96-cj99. In https://github.com/basecamp/trix/pull/1149, we added sanitation for Trix attachments with a text/html content type. However, Trix only checks the content type on the paste event's dataTransfer object. As long as the dataTransfer has a content type of text/html, Trix parses its contents and creates an Attachment with them, even if the attachment itself doesn't have a text/html content type. Trix then uses the attachment content to set the attachment element's innerHTML. Impact An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Patches Update Recommendation: Users…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qm2q-9f3q-2vcv
- Revision 1 · created ·
Published from osv record GHSA-qm2q-9f3q-2vcv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-43368 Advisory: Trix has a cross-site Scripting vulnerability on copy & paste IDs: CVE-2024-43368, GHSA-qm2q-9f3q-2vcv Record: https://patchnext.com/advisories/cve-2024-43368 (revision 2, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: trix 2.1.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm trix: affected < 2.1.4; fixed in 2.1.4 ## Suggested inspection (read-only) - `npm ls trix --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on trix. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qm2q-9f3q-2vcv (OSV record GHSA-qm2q-9f3q-2vcv lists affected ranges: npm trix >=0 <2.1.4 (fixed)) - Verified: https://github.com/advisories/GHSA-qm2q-9f3q-2vcv (GitHub-reviewed advisory GHSA-qm2q-9f3q-2vcv lists affected ranges: npm trix >=0 <2.1.4) Commands are suggestions: review each one before running it.
Loading voting…