Fonoster is vulnerable to directory traversal
CVE-2024-43035GHSA-9fv2-c7v6-p45w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fonoster/voice 0.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @fonoster/voice
- Affected
- >= 0.5.5, < 0.6.1
- Fixed in
- 0.6.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9fv2-c7v6-p45w lists affected ranges: npm @fonoster/voice >=0.5.5 <0.6.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9fv2-c7v6-p45w lists affected ranges: npm @fonoster/voice >=0.5.5 <0.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
- EPSS
- CVE-2024-43035: 2.40% estimated exploitation activity in the next 30 days; percentile 84.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Fonoster 0.5.5 before 0.6.1 allows ../ directory traversal to read arbitrary files via the /sounds/:file or /tts/:file VoiceServer endpoint. This occurs in serveFiles in mods/voice/src/utils.ts. NOTE: serveFiles exists in 0.5.5 but not in the next release, 0.6.1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9fv2-c7v6-p45w
- Revision 1 · created ·
Published from osv record GHSA-9fv2-c7v6-p45w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-43035 Advisory: Fonoster is vulnerable to directory traversal IDs: CVE-2024-43035, GHSA-9fv2-c7v6-p45w Record: https://patchnext.com/advisories/cve-2024-43035 (revision 2, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @fonoster/voice 0.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @fonoster/voice: affected >= 0.5.5, < 0.6.1; fixed in 0.6.1 ## Suggested inspection (read-only) - `npm ls @fonoster/voice --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @fonoster/voice. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9fv2-c7v6-p45w (OSV record GHSA-9fv2-c7v6-p45w lists affected ranges: npm @fonoster/voice >=0.5.5 <0.6.1 (fixed)) - Verified: https://github.com/advisories/GHSA-9fv2-c7v6-p45w (GitHub-reviewed advisory GHSA-9fv2-c7v6-p45w lists affected ranges: npm @fonoster/voice >=0.5.5 <0.6.1) Commands are suggestions: review each one before running it.
Loading voting…