MLflow allows low privilege users to delete any artifact
CVE-2024-4263GHSA-p4jx-q62p-x5jr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mlflow 2.10.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI mlflow
- Affected
- < 2.10.1
- Fixed in
- 2.10.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p4jx-q62p-x5jr lists affected ranges: PyPI mlflow >=0 <2.10.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p4jx-q62p-x5jr lists affected ranges: PyPI mlflow >=0 <2.10.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
- EPSS
- CVE-2024-4263: 0.33% estimated exploitation activity in the next 30 days; percentile 26.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A broken access control vulnerability exists in mlflow/mlflow versions before 2.10.1, where low privilege users with only EDIT permissions on an experiment can delete any artifacts. This issue arises due to the lack of proper validation for DELETE requests by users with EDIT permissions, allowing them to perform unauthorized deletions of artifacts. The vulnerability specifically affects the handling of artifact deletions within the application, as demonstrated by the ability of a low privilege user to delete a directory inside an artifact using a DELETE request, despite the official documentation stating that users with EDIT permission can only read and update artifacts, not delete them.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-p4jx-q62p-x5jr
- Revision 1 · created ·
Published from osv record GHSA-p4jx-q62p-x5jr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-4263 Advisory: MLflow allows low privilege users to delete any artifact IDs: CVE-2024-4263, GHSA-p4jx-q62p-x5jr Record: https://patchnext.com/advisories/cve-2024-4263 (revision 2, source checked 26 Oct 2026, 13:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mlflow 2.10.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mlflow: affected < 2.10.1; fixed in 2.10.1 ## Suggested inspection (read-only) - `python -m pip show mlflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mlflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p4jx-q62p-x5jr (OSV record GHSA-p4jx-q62p-x5jr lists affected ranges: PyPI mlflow >=0 <2.10.1 (fixed)) - Verified: https://github.com/advisories/GHSA-p4jx-q62p-x5jr (GitHub-reviewed advisory GHSA-p4jx-q62p-x5jr lists affected ranges: PyPI mlflow >=0 <2.10.1) Commands are suggestions: review each one before running it.
Loading voting…