Skip to content

← Actionable
Medium, CVSS 5.9

Security Update for the OPC UA .NET Standard Stack

CVE-2024-42512GHSA-h958-fxgg-g7w3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (opcfoundation.netstandard.opc.ua.core 1.5.374.158), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2024-42512: 0.59% estimated exploitation activity in the next 30 days; percentile 48.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

This security update resolves a vulnerability in the OPC UA .NET Standard Stack that allows an unauthorized attacker to bypass application authentication when the deprecated Basic128Rsa15 security policy is enabled. Note that the Basic128Rsa15 is disabled by default so most users will not be affected. When this patch is applied the Server closes all channels using the Basic128Rsa15 if an attack is detected. This introduces a DoS before any compromise can occur which is preferable to a compromise. To prevent this failure, applications must stop using Basic128Rsa15.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h958-fxgg-g7w3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-42512

Advisory: Security Update for the OPC UA .NET Standard Stack
IDs: CVE-2024-42512, GHSA-h958-fxgg-g7w3
Record: https://patchnext.com/advisories/cve-2024-42512 (revision 1, source checked 26 Oct 2026, 17:03 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: opcfoundation.netstandard.opc.ua.core 1.5.374.158. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet opcfoundation.netstandard.opc.ua.core: affected < 1.5.374.158; fixed in 1.5.374.158

## Suggested inspection (read-only)
- NuGet opcfoundation.netstandard.opc.ua.core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on opcfoundation.netstandard.opc.ua.core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h958-fxgg-g7w3 (GitHub-reviewed advisory GHSA-h958-fxgg-g7w3 lists affected ranges: NuGet opcfoundation.netstandard.opc.ua.core >=0 <1.5.374.158)

Commands are suggestions: review each one before running it.

Loading voting…