Cilium leaks information via incorrect ReferenceGrant update logic in Gateway API
CVE-2024-42486GHSA-vwf8-q6fw-4wcm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cilium/cilium 1.16.1, 1.15.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.16.0, <= 1.16.0>= 1.15.0, < 1.15.8
- Fixed in
- 1.15.8, 1.16.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vwf8-q6fw-4wcm lists affected ranges: Go github.com/cilium/cilium >=1.16.0 =1.15.0 <1.15.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
- EPSS
- CVE-2024-42486: 0.57% estimated exploitation activity in the next 30 days; percentile 47.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Due to ReferenceGrant changes not being immediately propagated in Cilium's GatewayAPI controller, Gateway resources are able to access secrets in other namespaces after the associated ReferenceGrant has been revoked. This can lead to Gateways continuing to establish sessions using secrets that they should no longer have access to. Patches This issue was resolved in https://github.com/cilium/cilium/pull/34032. This issue affects: - Cilium v1.15 between v1.15.0 and v1.15.7 inclusive - Cilium v1.16.0 This issue has been patched in: - Cilium v1.15.8 - Cilium v1.16.1 Workarounds Any modification of a related Gateway/HTTPRoute/GRPCRoute/TCPRoute CRD (for example, adding any label to any of these resources) will trigger a reconciliation of ReferenceGrants on an affected cluster. Acknowledgements The Cilium community has worked together with members of Cure53 and Isovalent to prepare these mitigations. Special thanks to @sayboras for resolving this issue. For more information If you…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vwf8-q6fw-4wcm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-42486 Advisory: Cilium leaks information via incorrect ReferenceGrant update logic in Gateway API IDs: CVE-2024-42486, GHSA-vwf8-q6fw-4wcm Record: https://patchnext.com/advisories/cve-2024-42486 (revision 1, source checked 26 Oct 2026, 15:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/cilium/cilium 1.16.1, 1.15.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/cilium/cilium: affected >= 1.16.0, <= 1.16.0; >= 1.15.0, < 1.15.8; fixed in 1.15.8, 1.16.1 ## Suggested inspection (read-only) - Go github.com/cilium/cilium: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/cilium/cilium. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vwf8-q6fw-4wcm (GitHub-reviewed advisory GHSA-vwf8-q6fw-4wcm lists affected ranges: Go github.com/cilium/cilium >=1.16.0 =1.15.0 <1.15.8) Commands are suggestions: review each one before running it.
Loading voting…