Apache Airflow Providers FAB Insufficient Session Expiration vulnerability
CVE-2024-42447GHSA-62qf-qm3g-fvcw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow-providers-fab 1.2.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow-providers-fab
- Affected
- >= 1.2.0, < 1.2.2
- Fixed in
- 1.2.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-62qf-qm3g-fvcw lists affected ranges: PyPI apache-airflow-providers-fab >=1.2.0 <1.2.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-62qf-qm3g-fvcw lists affected ranges: PyPI apache-airflow-providers-fab >=1.2.0 <1.2.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-42447: 0.93% estimated exploitation activity in the next 30 days; percentile 60.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Insufficient Session Expiration vulnerability in Apache Airflow Providers FAB. This issue affects Apache Airflow Providers FAB: 1.2.1 (when used with Apache Airflow 2.9.3) and FAB 1.2.0 for all Airflow versions. The FAB provider prevented the user from logging out. FAB provider 1.2.1 only affected Airflow 2.9.3 (earlier and later versions of Airflow are not affected) FAB provider 1.2.0 affected all versions of Airflow. Users who run Apache Airflow 2.9.3 are recommended to upgrade to Apache Airflow Providers FAB version 1.2.2 which fixes the issue. Users who run Any Apache Airflow version and have FAB provider 1.2.0 are recommended to upgrade to Apache Airflow Providers FAB version 1.2.2 which fixes the issue. Also upgrading Apache Airflow to latest version available is recommended. Note: Early version of Airflow reference container images of Airflow 2.9.3 and constraint files contained FAB provider 1.2.1 version, but this is fixed in updated versions of the images. Users are advised…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-62qf-qm3g-fvcw
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-62qf-qm3g-fvcw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-42447 Advisory: Apache Airflow Providers FAB Insufficient Session Expiration vulnerability IDs: CVE-2024-42447, GHSA-62qf-qm3g-fvcw Record: https://patchnext.com/advisories/cve-2024-42447 (revision 3, source checked 26 Oct 2026, 13:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow-providers-fab 1.2.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow-providers-fab: affected >= 1.2.0, < 1.2.2; fixed in 1.2.2 ## Suggested inspection (read-only) - `python -m pip show apache-airflow-providers-fab`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow-providers-fab. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-62qf-qm3g-fvcw (OSV record GHSA-62qf-qm3g-fvcw lists affected ranges: PyPI apache-airflow-providers-fab >=1.2.0 <1.2.2 (fixed)) - Verified: https://github.com/advisories/GHSA-62qf-qm3g-fvcw (GitHub-reviewed advisory GHSA-62qf-qm3g-fvcw lists affected ranges: PyPI apache-airflow-providers-fab >=1.2.0 <1.2.2) Commands are suggestions: review each one before running it.
Loading voting…