Shopware vulnerable to Server Side Template Injection in Twig using deprecation silence tag
CVE-2024-42355GHSA-27wp-jvhw-v4xp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopware/core 6.6.5.1, 6.5.8.13; shopware/platform 6.6.5.1, 6.5.8.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist shopware/core
- Affected
- <= 6.5.8.12>= 6.6.0.0, <= 6.6.5.0
- Fixed in
- 6.5.8.13, 6.6.5.1
Packagist shopware/platform
- Affected
- <= 6.5.8.12>= 6.6.0.0, <= 6.6.5.0
- Fixed in
- 6.5.8.13, 6.6.5.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-27wp-jvhw-v4xp lists affected ranges: Packagist shopware/core >=0 =6.6.0.0 =0 =6.6.0.0 <=6.6.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-42355: 0.86% estimated exploitation activity in the next 30 days; percentile 58.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Shopware has a new Twig Tag swsilentfeaturecall which silences deprecation messages while triggered in this tag. It accepts as parameter a string the feature flag name to silence, but this parameter is not escaped properly and allows execution of code. Patches Update to Shopware 6.6.5.1 or 6.5.8.13 Workarounds For older versions of 6.2, 6.3, and 6.4, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-27wp-jvhw-v4xp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-42355 Advisory: Shopware vulnerable to Server Side Template Injection in Twig using deprecation silence tag IDs: CVE-2024-42355, GHSA-27wp-jvhw-v4xp Record: https://patchnext.com/advisories/cve-2024-42355 (revision 1, source checked 26 Oct 2026, 14:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shopware/core 6.6.5.1, 6.5.8.13; shopware/platform 6.6.5.1, 6.5.8.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist shopware/core: affected <= 6.5.8.12; >= 6.6.0.0, <= 6.6.5.0; fixed in 6.5.8.13, 6.6.5.1 - Packagist shopware/platform: affected <= 6.5.8.12; >= 6.6.0.0, <= 6.6.5.0; fixed in 6.5.8.13, 6.6.5.1 ## Suggested inspection (read-only) - Packagist shopware/core: check the installed version with your package manager. - Packagist shopware/platform: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shopware/core, shopware/platform. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-27wp-jvhw-v4xp (GitHub-reviewed advisory GHSA-27wp-jvhw-v4xp lists affected ranges: Packagist shopware/core >=0 =6.6.0.0 =0 =6.6.0.0 <=6.6.5.0) Commands are suggestions: review each one before running it.
Loading voting…