Shopware vulnerable to Improper Access Control with ManyToMany associations in store-api
CVE-2024-42354GHSA-hhcq-ph6w-494g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopware/core 6.6.5.1, 6.5.8.13; shopware/platform 6.6.5.1, 6.5.8.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist shopware/core
- Affected
- <= 6.5.8.12>= 6.6.0.0, <= 6.6.5.0
- Fixed in
- 6.5.8.13, 6.6.5.1
Packagist shopware/platform
- Affected
- <= 6.5.8.12>= 6.6.0.0, <= 6.6.5.0
- Fixed in
- 6.5.8.13, 6.6.5.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hhcq-ph6w-494g lists affected ranges: Packagist shopware/core >=0 =6.6.0.0 =0 =6.6.0.0 <=6.6.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-42354: 0.43% estimated exploitation activity in the next 30 days; percentile 37.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The store-API works with regular entities and not expose all fields for the public API; fields need to be marked as ApiAware in the EntityDefinition. So only ApiAware fields of the EntityDefinition will be encoded to the final JSON. The processing of the Criteria did not considered ManyToMany associations and so they were not considered properly and the protections didn't get used. This issue cannot be reproduced with the default entities by Shopware, but can be triggered with extensions. Patches Update to Shopware 6.6.5.1 or 6.5.8.13. Workarounds For older versions of 6.2, 6.3, and 6.4, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hhcq-ph6w-494g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-42354 Advisory: Shopware vulnerable to Improper Access Control with ManyToMany associations in store-api IDs: CVE-2024-42354, GHSA-hhcq-ph6w-494g Record: https://patchnext.com/advisories/cve-2024-42354 (revision 1, source checked 26 Oct 2026, 14:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shopware/core 6.6.5.1, 6.5.8.13; shopware/platform 6.6.5.1, 6.5.8.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist shopware/core: affected <= 6.5.8.12; >= 6.6.0.0, <= 6.6.5.0; fixed in 6.5.8.13, 6.6.5.1 - Packagist shopware/platform: affected <= 6.5.8.12; >= 6.6.0.0, <= 6.6.5.0; fixed in 6.5.8.13, 6.6.5.1 ## Suggested inspection (read-only) - Packagist shopware/core: check the installed version with your package manager. - Packagist shopware/platform: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shopware/core, shopware/platform. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hhcq-ph6w-494g (GitHub-reviewed advisory GHSA-hhcq-ph6w-494g lists affected ranges: Packagist shopware/core >=0 =6.6.0.0 =0 =6.6.0.0 <=6.6.5.0) Commands are suggestions: review each one before running it.
Loading voting…