PYSEC-2024-273
CVE-2024-42346GHSA-x6w7-3gwf-qr9r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (galaxy-auth 24.1.1; galaxy-data 24.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI galaxy-auth
- Affected
- < 24.1.1
- Fixed in
- 24.1.1
PyPI galaxy-data
- Affected
- < 24.1.1
- Fixed in
- 24.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2024-272 lists affected ranges: PyPI galaxy-auth >=0 <24.1.1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2024-273 lists affected ranges: PyPI galaxy-data >=0 <24.1.1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2024-42346: 0.77% estimated exploitation activity in the next 30 days; percentile 55.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Galaxy is a free, open-source system for analyzing data, authoring workflows, training and education, publishing tools, managing infrastructure, and more. The editor visualization, /visualizations endpoint, can be used to store HTML tags and trigger javascript execution upon edit operation. All supported branches of Galaxy (and more back to release_20.05) were amended with the supplied patches. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record PYSEC-2024-273
- Revision 1 · created ·
Published from osv record PYSEC-2024-272
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-42346 Advisory: PYSEC-2024-273 IDs: CVE-2024-42346, GHSA-x6w7-3gwf-qr9r Record: https://patchnext.com/advisories/cve-2024-42346 (revision 2, source checked 24 Oct 2026, 04:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: galaxy-auth 24.1.1; galaxy-data 24.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI galaxy-auth: affected < 24.1.1; fixed in 24.1.1 - PyPI galaxy-data: affected < 24.1.1; fixed in 24.1.1 ## Suggested inspection (read-only) - `python -m pip show galaxy-auth`: prints the installed version. Run with the environment that serves production active. - `python -m pip show galaxy-data`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on galaxy-auth, galaxy-data. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/PYSEC-2024-272 (OSV record PYSEC-2024-272 lists affected ranges: PyPI galaxy-auth >=0 <24.1.1 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2024-273 (OSV record PYSEC-2024-273 lists affected ranges: PyPI galaxy-data >=0 <24.1.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…