Kirby has insufficient permission checks in the language settings
CVE-2024-41964GHSA-jm9m-rqr3-wfmh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 4.3.1, 3.10.1.1, 3.9.8.2, 3.8.4.4, 3.7.5.5, 3.6.6.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getkirby/cms
- Affected
- <= 3.6.6.5>= 3.7.0, <= 3.7.5.4>= 3.8.0, <= 3.8.4.3>= 3.9.0, <= 3.9.8.1>= 3.10.0, <= 3.10.1>= 4.0.0, <= 4.3.0
- Fixed in
- 3.10.1.1, 4.3.1, 3.8.4.4, 3.9.8.2, 3.6.6.6, 3.7.5.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jm9m-rqr3-wfmh lists affected ranges: Packagist getkirby/cms >=0 =3.7.0 =3.8.0 =3.9.0 =3.10.0 =4.0.0 <=4.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-41964: 0.48% estimated exploitation activity in the next 30 days; percentile 41.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
TL;DR This vulnerability affects all Kirby sites with enabled languages option that might have potential attackers in the group of authenticated Panel users. If you have disabled the languages and/or api option and don't call any methods in your code that cause a write access to languages (language creation, update or deletion), your site is not affected. ---- Introduction Kirby allows to restrict the permissions of specific user roles. Users of that role can only perform permitted actions. Permissions for creating and deleting languages have already existed and could be configured, but were not enforced by Kirby's frontend or backend code. A permission for updating existing languages has not existed before the patched versions. So disabling the languages. wildcard permission for a role could not have prohibited updates to existing language definitions. Impact The missing permission checks allowed attackers with Panel access to manipulate the language definitions. The language…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jm9m-rqr3-wfmh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-41964 Advisory: Kirby has insufficient permission checks in the language settings IDs: CVE-2024-41964, GHSA-jm9m-rqr3-wfmh Record: https://patchnext.com/advisories/cve-2024-41964 (revision 1, source checked 26 Oct 2026, 14:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 4.3.1, 3.10.1.1, 3.9.8.2, 3.8.4.4, 3.7.5.5, 3.6.6.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getkirby/cms: affected <= 3.6.6.5; >= 3.7.0, <= 3.7.5.4; >= 3.8.0, <= 3.8.4.3; >= 3.9.0, <= 3.9.8.1; >= 3.10.0, <= 3.10.1; >= 4.0.0, <= 4.3.0; fixed in 3.10.1.1, 4.3.1, 3.8.4.4, 3.9.8.2, 3.6.6.6, 3.7.5.5 ## Suggested inspection (read-only) - Packagist getkirby/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getkirby/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jm9m-rqr3-wfmh (GitHub-reviewed advisory GHSA-jm9m-rqr3-wfmh lists affected ranges: Packagist getkirby/cms >=0 =3.7.0 =3.8.0 =3.9.0 =3.10.0 =4.0.0 <=4.3.0) Commands are suggestions: review each one before running it.
Loading voting…