Skip to content

← Actionable
Medium, CVSS 5.3amended

PheonixAppAPI has visible Encoding Maps

CVE-2024-41951GHSA-258h-f687-4226

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pheonixappapi 0.2.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-41951: 0.17% estimated exploitation activity in the next 30 days; percentile 6.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This is a kind of moderate issue. The impact is not big for normal users but can be for users who want to secure their code/files/etc. The issue is that the map of encoding/decoding languages are visible in code. Patches The Problem was patched in 0.2.5, so you should try to upgrade to the 0.2.5 version. For 0.2.5 version users Please run the postinstall.py file inside the Scripts folder after downloading from pip. Workarounds There is a fix to this problem but it requires modifying the code. Modifying the code can lead to more issues. References There are currently no references to this problem. NOTE: If you get a error regarding a function like - getkey() or something like that, please re-run the file postinstall.py inside Scripts folder

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-258h-f687-4226

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-258h-f687-4226

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-41951

Advisory: PheonixAppAPI has visible Encoding Maps
IDs: CVE-2024-41951, GHSA-258h-f687-4226
Record: https://patchnext.com/advisories/cve-2024-41951 (revision 3, source checked 26 Oct 2026, 13:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pheonixappapi 0.2.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pheonixappapi: affected < 0.2.5; fixed in 0.2.5

## Suggested inspection (read-only)
- `python -m pip show pheonixappapi`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pheonixappapi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-258h-f687-4226 (OSV record GHSA-258h-f687-4226 lists affected ranges: PyPI pheonixappapi >=0 <0.2.5 (fixed))
- Verified: https://github.com/advisories/GHSA-258h-f687-4226 (GitHub-reviewed advisory GHSA-258h-f687-4226 lists affected ranges: PyPI pheonixappapi >=0 <0.2.5)

Commands are suggestions: review each one before running it.

Loading voting…