Insecure Jinja2 templates rendered in Haystack Components can lead to RCE
CVE-2024-41950GHSA-hx9v-6r9f-w677
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (haystack-ai 2.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI haystack-ai
- Affected
- < 2.3.1
- Fixed in
- 2.3.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hx9v-6r9f-w677 lists affected ranges: PyPI haystack-ai >=0 <2.3.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hx9v-6r9f-w677 lists affected ranges: PyPI haystack-ai >=0 <2.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.7 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-41950: 1.17% estimated exploitation activity in the next 30 days; percentile 67.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Haystack clients that let their users create and run Pipelines from scratch are vulnerable to remote code executions. Certain Components in Haystack use Jinja2 templates, if anyone can create and render that template on the client machine they run any code. Patches The problem has been fixed with PRs deepset-ai/haystack#8095 and deepset-ai/haystack#8096. Both have been released with Haystack 2.3.1. Workarounds Prevent users from running the affected Components, or only let users use preselected templates. References The list of impacted Components can be found in the release notes for 2.3.1. https://github.com/deepset-ai/haystack/releases/tag/v2.3.1
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-hx9v-6r9f-w677
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-hx9v-6r9f-w677
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-41950 Advisory: Insecure Jinja2 templates rendered in Haystack Components can lead to RCE IDs: CVE-2024-41950, GHSA-hx9v-6r9f-w677 Record: https://patchnext.com/advisories/cve-2024-41950 (revision 3, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: haystack-ai 2.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI haystack-ai: affected < 2.3.1; fixed in 2.3.1 ## Suggested inspection (read-only) - `python -m pip show haystack-ai`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on haystack-ai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hx9v-6r9f-w677 (OSV record GHSA-hx9v-6r9f-w677 lists affected ranges: PyPI haystack-ai >=0 <2.3.1 (fixed)) - Verified: https://github.com/advisories/GHSA-hx9v-6r9f-w677 (GitHub-reviewed advisory GHSA-hx9v-6r9f-w677 lists affected ranges: PyPI haystack-ai >=0 <2.3.1) Commands are suggestions: review each one before running it.
Loading voting…