Mattermost allows team admins to promote guests to team admins
CVE-2024-4195GHSA-5fh7-7mw7-mmx5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost-server 9.5.3, 8.1.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost-server
- Affected
- >= 9.5.0, <= 9.5.2>= 8.1.0, <= 8.1.11
- Fixed in
- 9.5.3, 8.1.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5fh7-7mw7-mmx5 lists affected ranges: Go github.com/mattermost/mattermost-server >=9.5.0 =8.1.0 <=8.1.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2024-4195: 0.50% estimated exploitation activity in the next 30 days; percentile 43.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 9.6.0, 9.5.x before 9.5.3, and 8.1.x before 8.1.12 fail to fully validate role changes, which allows an attacker authenticated as a team admin to promote guests to team admins via crafted HTTP requests.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5fh7-7mw7-mmx5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-4195 Advisory: Mattermost allows team admins to promote guests to team admins IDs: CVE-2024-4195, GHSA-5fh7-7mw7-mmx5 Record: https://patchnext.com/advisories/cve-2024-4195 (revision 1, source checked 26 Oct 2026, 15:03 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost-server 9.5.3, 8.1.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost-server: affected >= 9.5.0, <= 9.5.2; >= 8.1.0, <= 8.1.11; fixed in 9.5.3, 8.1.12 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5fh7-7mw7-mmx5 (GitHub-reviewed advisory GHSA-5fh7-7mw7-mmx5 lists affected ranges: Go github.com/mattermost/mattermost-server >=9.5.0 =8.1.0 <=8.1.11) Commands are suggestions: review each one before running it.
Loading voting…