Skip to content

← Actionable
Low, CVSS 2.1

biscuit-auth vulnerable to public key confusion in third party block

CVE-2024-41949GHSA-p9w4-585h-g3c7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (biscuit-auth 5.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io biscuit-auth

    Affected
    >= 4.0.0, < 5.0.0
    Fixed in
    5.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N · score source
EPSS
  • CVE-2024-41949: 0.24% estimated exploitation activity in the next 30 days; percentile 14.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Third-party blocks can be generated without transferring the whole token to the third-party authority. Instead, a ThirdPartyBlock request can be sent, providing only the necessary info to generate a third-party block and to sign it: - the public key of the previous block (used in the signature) - the public keys part of the token symbol table (for public key interning in datalog expressions) A third-part block request forged by a malicious user can trick the third-party authority into generating datalog trusting the wrong keypair. Consider the following example (nominal case) - Authority A emits the following token: check if thirdparty("b") trusting ${pubkeyB} - The well-behaving holder then generates a third-party block request based on the token and sends it to third-party authority B - Third-party B generates the following third-party block thirdparty("b"); check if thirdparty("c") trusting ${pubkeyC} - The token holder now must obtain a third-party block from third party C to be…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p9w4-585h-g3c7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-41949

Advisory: biscuit-auth vulnerable to public key confusion in third party block
IDs: CVE-2024-41949, GHSA-p9w4-585h-g3c7
Record: https://patchnext.com/advisories/cve-2024-41949 (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: biscuit-auth 5.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io biscuit-auth: affected >= 4.0.0, < 5.0.0; fixed in 5.0.0

## Suggested inspection (read-only)
- crates.io biscuit-auth: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on biscuit-auth.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p9w4-585h-g3c7 (GitHub-reviewed advisory GHSA-p9w4-585h-g3c7 lists affected ranges: crates.io biscuit-auth >=4.0.0 <5.0.0)

Commands are suggestions: review each one before running it.

Loading voting…