JupyterHub has a privilege escalation vulnerability with the admin:users scope
CVE-2024-41942GHSA-9x4q-3gxw-849f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyterhub 5.1.0, 4.1.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyterhub
- Affected
- < 4.1.6>= 5.0.0, < 5.1.0
- Fixed in
- 5.1.0, 4.1.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9x4q-3gxw-849f lists affected ranges: PyPI jupyterhub >=0 =5.0.0 <5.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9x4q-3gxw-849f lists affected ranges: PyPI jupyterhub >=0 =5.0.0 <5.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-41942: 0.59% estimated exploitation activity in the next 30 days; percentile 48.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary If a user is granted the admin:users scope, they may escalate their own privileges by making themselves a full admin user. Details The admin:users scope allows a user to edit user records: admin:users Read, write, create and delete users and their authentication state, not including their servers or tokens. -- https://jupyterhub.readthedocs.io/en/stable/rbac/scopes.html#available-scopes However, this includes making users admins. Admin users are granted scopes beyond admin:users making this a mechanism by which granted scopes may be escalated. Impact The impact is relatively small in that admin:users is already an extremely privileged scope only granted to trusted users. In effect, admin:users is equivalent to admin=True, which is not intended. Note that the change here only prevents escalation to the built-in JupyterHub admin role that has unrestricted permissions. It does not prevent users with e.g. groups permissions from granting themselves or other users permissions via…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9x4q-3gxw-849f
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-9x4q-3gxw-849f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-41942 Advisory: JupyterHub has a privilege escalation vulnerability with the `admin:users` scope IDs: CVE-2024-41942, GHSA-9x4q-3gxw-849f Record: https://patchnext.com/advisories/cve-2024-41942 (revision 3, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyterhub 5.1.0, 4.1.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyterhub: affected < 4.1.6; >= 5.0.0, < 5.1.0; fixed in 5.1.0, 4.1.6 ## Suggested inspection (read-only) - `python -m pip show jupyterhub`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyterhub. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9x4q-3gxw-849f (OSV record GHSA-9x4q-3gxw-849f lists affected ranges: PyPI jupyterhub >=0 =5.0.0 <5.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-9x4q-3gxw-849f (GitHub-reviewed advisory GHSA-9x4q-3gxw-849f lists affected ranges: PyPI jupyterhub >=0 =5.0.0 <5.1.0) Commands are suggestions: review each one before running it.
Loading voting…