Skip to content

← Actionable
Medium, CVSS 5.1

Mattermost allows remote actor to set arbitrary RemoteId values for synced users

CVE-2024-41926GHSA-9fpw-c9x7-cv3j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 9.9.1, 9.5.7, 8.0.0-20240604093018-5114c3b7cdb8; github.com/mattermost/mattermost 5.3.2-0.20240604093018-5114c3b7cdb8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-9fpw-c9x7-cv3j lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=9.5.0 =9.9.0 =0 =0 <5.3.2-0.20240604093018-5114c3b7cdb8

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N · score source
EPSS
  • CVE-2024-41926: 0.18% estimated exploitation activity in the next 30 days; percentile 6.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mattermost versions 9.9.x <= 9.9.0 and 9.5.x <= 9.5.6 fail to validate the source of sync messages and only allow the correct remote IDs, which allows a malicious remote to set arbitrary RemoteId values for synced users and therefore claim that a user was synced from another remote.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9fpw-c9x7-cv3j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-41926

Advisory: Mattermost allows remote actor to set arbitrary RemoteId values for synced users
IDs: CVE-2024-41926, GHSA-9fpw-c9x7-cv3j
Record: https://patchnext.com/advisories/cve-2024-41926 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 9.9.1, 9.5.7, 8.0.0-20240604093018-5114c3b7cdb8; github.com/mattermost/mattermost 5.3.2-0.20240604093018-5114c3b7cdb8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost/server/v8: affected >= 9.5.0, < 9.5.7; >= 9.9.0, <= 9.9.0; < 8.0.0-20240604093018-5114c3b7cdb8; fixed in 8.0.0-20240604093018-5114c3b7cdb8, 9.9.1, 9.5.7
- Go github.com/mattermost/mattermost: affected < 5.3.2-0.20240604093018-5114c3b7cdb8; fixed in 5.3.2-0.20240604093018-5114c3b7cdb8

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager.
- Go github.com/mattermost/mattermost: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9fpw-c9x7-cv3j (GitHub-reviewed advisory GHSA-9fpw-c9x7-cv3j lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=9.5.0 =9.9.0 =0 =0 <5.3.2-0.20240604093018-5114c3b7cdb8)

Commands are suggestions: review each one before running it.

Loading voting…