fast-xml-parser vulnerable to ReDOS at currency parsing
CVE-2024-41818GHSA-mpg4-rc92-vx8v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-xml-parser 4.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fast-xml-parser
- Affected
- >= 4.3.5, < 4.4.1
- Fixed in
- 4.4.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mpg4-rc92-vx8v lists affected ranges: npm fast-xml-parser >=4.3.5 <4.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mpg4-rc92-vx8v lists affected ranges: npm fast-xml-parser >=4.3.5 <4.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-41818: 0.83% estimated exploitation activity in the next 30 days; percentile 57.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A ReDOS that exists on currency.js was discovered by Gauss Security Labs R&D team. Details https://github.com/NaturalIntelligence/fast-xml-parser/blob/v4.4.0/src/v5/valueParsers/currency.js#L10 contains a vulnerable regex PoC pass the following string '\t'.repeat(13337) + '.' Impact Denial of service during currency parsing in experimental version 5 of fast-xml-parser-library https://gauss-security.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mpg4-rc92-vx8v
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-mpg4-rc92-vx8v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-41818 Advisory: fast-xml-parser vulnerable to ReDOS at currency parsing IDs: CVE-2024-41818, GHSA-mpg4-rc92-vx8v Record: https://patchnext.com/advisories/cve-2024-41818 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fast-xml-parser 4.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fast-xml-parser: affected >= 4.3.5, < 4.4.1; fixed in 4.4.1 ## Suggested inspection (read-only) - `npm ls fast-xml-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fast-xml-parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mpg4-rc92-vx8v (OSV record GHSA-mpg4-rc92-vx8v lists affected ranges: npm fast-xml-parser >=4.3.5 <4.4.1 (fixed)) - Verified: https://github.com/advisories/GHSA-mpg4-rc92-vx8v (GitHub-reviewed advisory GHSA-mpg4-rc92-vx8v lists affected ranges: npm fast-xml-parser >=4.3.5 <4.4.1) Commands are suggestions: review each one before running it.
Loading voting…