Skip to content

← Actionable
Low, CVSS 2.1

ipl/web's ipl\Web\Common\CsrfCounterMeasure is susceptible to CSRF

CVE-2024-41811GHSA-w9pg-7c3h-fc8j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ipl/web 0.10.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist ipl/web

    Affected
    < 0.10.1
    Fixed in
    0.10.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-41811: 0.18% estimated exploitation activity in the next 30 days; percentile 8.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Some of the recent development by Icinga is, under certain circumstances, susceptible to cross site request forgery. (CSRF) Affected products: Icinga Web (=2.12.0) Icinga DB Web (=1.0.0) Icinga Notifications Web (=0.1.0) Icinga Web JIRA Integration (=1.3.0) All affected products, in any version, will be unaffected by this once icinga-php-library is upgraded. Patches Version 0.10.1 will include a fix for this. It will be published as part of the icinga-php-library v0.14.1 release.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w9pg-7c3h-fc8j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-41811

Advisory: ipl/web's `ipl\Web\Common\CsrfCounterMeasure` is susceptible to CSRF
IDs: CVE-2024-41811, GHSA-w9pg-7c3h-fc8j
Record: https://patchnext.com/advisories/cve-2024-41811 (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ipl/web 0.10.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist ipl/web: affected < 0.10.1; fixed in 0.10.1

## Suggested inspection (read-only)
- Packagist ipl/web: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ipl/web.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w9pg-7c3h-fc8j (GitHub-reviewed advisory GHSA-w9pg-7c3h-fc8j lists affected ranges: Packagist ipl/web >=0 <0.10.1)

Commands are suggestions: review each one before running it.

Loading voting…